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Introduction
This guide is designed to provide Sage 200 Business Partners and customers with all the
information required to install and upgrade Sage 200c Professional.

If you're also using Sage 200 CRM, you'll also need to read the relevant Sage 200 CRM guides.

n Sage 200 CRM Installation and Upgrade Guide.

n CRM Connector Installation Guide.

Note: If you are installing Sage 200 Extra Online, please see the Sage 200 Extra Online
Deployment and Installation Guide.

Guides are available from:
http://desktophelp.sage.co.uk/sage200/installation/Default.htm#cshid=guides

Required Knowledge
To install or upgrade to Sage 200c Professional you must have experience in:

n Configuring Microsoft SQL Server.

n Configuring Microsoft Internet Information Services (IIS).

n Configuring Microsoft Active Directory.

Please make sure that you read the relevant sections in this guide before you install or upgrade.
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Before you start
Before you install Sage 200c Professional on any site, you must check the system requirements
and check that the system is set up correctly.

This section tells you:

n What's new about installing this version.

n Supported software.

n How to check prerequisites.

n Security and firewall settings.

n Specifications for client and server machines.

n The application pools and website bindings.

6
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New for Sage 200c Professional

Winter 2018

Removal of Graphical Planner
Graphical Planner is no longer included with Sage 200c (from Winter 2018).

For more information, see this article: Graphical Planner - End of Support Policy (Ask Sage article
43549).

Summer 2018

Changes to supported operating systems and browsers
Support added Support removed for this version

Microsoft SQL Server 2017

Changes to log files
Log files for Sage 200c Professional are now stored in a different folder from the Summer 2018
release.

Log files will be stored in \users\<user>\appdata\local\sage\sage200\, instead of
\programdata\sage\sage200\.

Spring 2018
No changes.
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Winter 2017

Changes to the prerequisites
New prerequisite No longer required:

TLS 1.2 support required for Microsoft SQL Server by
default.

TLS 1.0 and 1.1 not supported by
default.

Installation process
If you're upgrading from 2017 Winter Edition onwards, you don't need to uninstall any Sage 200c
desktop apps from the server or client machines when upgrading to a new version. The new
version can be installed on top of the old version.

Summer 2017

Changes to supported operating systems and browsers
Support added Support removed for this version

Windows
Server 2016

Server 2008 R2

iOS v10 Terminal services virtual machine based desktop deployment - this was
previously supported with Server 2008 R2.

iOS 9 - apart from Sage 200 CRM

IE 10 - apart from Server 2012 only. Note: IE 10 is not supported for CRM on
any operating systems.

Changes to the prerequisites
New prerequisite No longer required:

Microsoft .NET Framework version 4.5.2 (or later).

Note: This may already be included if you have
installed a later version of .NET Framework.

Microsoft .NET Framework version 3.5
- now only required for BI.

.NET Extensibility 3.5
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New prerequisite No longer required:

ASP.NET

ASP.NET 3.5

New installation process
There is a new installation process for Sage 200c Professional. Instead of using a single installer to
install the server and client elements, these are now installed separately.

First you install Sage 200c Professional on the server. As part of the server installation, the client
installers are added to a file share: C:\Sage\Installers. At the end of the server installation links to
the file share are added to a web page. You can then send the link to this web page to the users
so that they can install required client elements.

The user installing or upgrading Sage 200c must have permission to write to the root of the C:\
drive.

If you're upgrading from 2017 Winter Edition onwards, you don't need to uninstall any Sage 200c
desktop apps from the server or client machines when upgrading to a new version. The new
version can be installed on top of the old version.

There's no longer a requirement to install any client elements on the server, unless you're using
BI.

The components for e-banking and the nominal link to payroll will need to be installed separately
when required. This can be done from the desktop app.
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Why have we made this change?
We've made this change to improve the upgrade process for Sage 200c.

The desktop apps are now installed using 'Click Once' technology. After you've installed Sage
200c Professional, you'll no longer need to uninstall any desktop apps from the client machines
when upgrading to a new version. Once a new version is installed on the server, the desktop apps
are automatically updated the next time a user opens them.

Installing e-Banking components
The changes to the installers mean that you must now install the e-Banking components for Sage
200c separately on each client PC that will use the service. Previously this was included as part of
the installation process.

This has now has two parts:

1. Install the Sage e-Banking component.

You do this from the desktop app ( Tools > Installers > Install eBanking components).

2. Install the e-Banking service for the required bank. This must be downloaded and installed
from the Sage website Sage e-Banking services for compatible banks.

Installing the nominal link
The changes to the installers mean that you must now install the additional component for the
nominal link for Sage 200c separately on each client PC that will use the service. Previously this
was included as part of the installation process.

You can do this from the desktop app ( Tools > Installers > Install nominal link
components).

Installing BI
The changes to the installers mean that there is a change to how BI should be installed. For sites
using BI, the Sage 200 desktop app (client) must also be installed on the server. You must make
sure that you're logged onto the server as the windows user set to run the scheduled task for BI.
This is to make sure the DLL files for the scheduled task are installed correctly.

Other changes

Excel Integrated reporting
This has been removed from Sage 200c Professional, as this has been replaced by new Excel
reporting functionality. This was removed by default from the desktop app in Sage 200 2015, but
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could be reinstated via System Administration. This is no longer possible in Sage 200c
Professional.
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Supported software

Operating systems
Server Client

Windows 7 SP1 (32-bit and 64-bit) (Professional, Enterprise & Ultimate Editions) 3 1

Windows 8.1 (32-bit and 64-bit) (Pro and Enterprise Editions) 1

Windows 10 (32-bit and 64-bit) (Pro and Enterprise Editions) 1

Windows Server 2012 (Standard, Essentials & Datacenter Editions) 3

Windows Server 2012 R2 (Standard, Essentials & Datacenter Editions) 2

Windows Server 2016 (Standard, Essentials & Datacenter Editions)

1 Not supported for production environments but may be used for demonstration and training purposes only.

2 Windows Server 2012 R2 with Updates version (released Nov 2014). If you use virtualised platforms, there is a known
performance issue with the Core Components when installed on this version of 2012 R2, when you use a minimum
hardware specification. This can be resolved by increasing the hardware specification.

3 If you are using the Sage Contact app or Pegg chatbot, the Azure Application Proxy Installer requires Windows 8.1,
Windows Server 2012 R2, or later versions of Windows.

Sage 200 migration tools
Classic
Migration tool

50 - 200
Migration tool

Windows 7 SP1 (32-bit and 64-bit) (Professional, Enterprise
& Ultimate Editions)

(32 bit only)

Windows 8.1 (32-bit and 64-bit) (Pro and Enterprise
Editions)

Windows 10 (32-bit and 64-bit) (Pro and Enterprise
Editions)

Windows Server 2012 (Standard, Essentials & Datacenter
Editions)

Windows Server 2012 R2 (Standard, Essentials &
Datacenter Editions)

Windows Server 2016 (Standard, Essentials & Datacenter
Editions)
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Sage connected apps - Sage Contact app and Pegg
chatbot
Sage connected apps refers to Sage Contact app and the Pegg chatbot, which connect to your

Office 365 account.

n The Microsoft Azure Active Directory Proxy Connector (used for the Sage connected apps),
requires Microsoft Windows 8.1, Windows Server 2012 R2, or later versions of Windows.

n The Sage connected apps can only be used with an Office 365 Business Premium or Enterprise
(E1, E3 or E5) subscription.

Remote Desktop Services (formerly
Terminal Services)

Server Client

Windows Server 2012 *

Windows Server 2012 R2 *

Windows Server 2016 *

* The application must be deployed using 'Session based Desktop Deployment' with a published
remote desktop. 'Virtual machine based desktop deployment' is not supported.

Requirements for deploying Remote Desktop Services:

n The Remote Desktop Services installation must be deployed using Session-based desktop
deployment.

Deployment using Virtual-machine based desktop deployment is not supported.

n Sage 200c is only supported when publishing the whole desktop environment through
Remote Desktop Services.

Delivering Sage 200c as a RemoteApp solution is not supported.

For Remote Desktop Services servers hosting Sage 200c client sessions, we recommend:

n At least 600MB memory per user on the server, for each client session running occasional or
one-off tasks, such as an account enquiry or price check.

n At least 1GB memory for each client session processing for any prolonged period of time, for
tasks such as checking in stock, or creating purchase orders.

n You should run large batch processes and updates on the local area network, or out of hours.
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SQL server
Server

Microsoft SQL Server 2017 - Standard, Business Intelligence, Enterprise & Datacenter
Editions (64-bit)

Microsoft SQL Server 2016 SP1- Standard, Business Intelligence, Enterprise &
Datacenter Editions (32 & 64-bit)

Microsoft SQL Server 2014 SP2 - Standard, Business Intelligence, Enterprise &
Datacenter Editions (32 & 64-bit).

Microsoft SQL Server 2012 SP3 - Standard, Enterprise & Datacenter Editions (32 & 64-bit
).

By default, Sage 200c now requires that your version of Microsoft SQL Server supports TLS
1.2.

To determine whether your current version of SQL Server already has support for TLS 1.2, or
whether you have to download an update to enable TLS 1.2 support, please see this Microsoft
support article: support.microsoft.com/en-us/help/3135244/tls-1-2-support-for-microsoft-sql-
server

If your version of Microsoft SQL Server does not support TLS 1.2, and you are unable to
upgrade at this time, you can manually configure Sage 200c to use TLS 1.0 or 1.1 instead. See
How do I configure Sage 200 to use TLS 1.0 or 1.1? on page 73.

Prerequisites for SQL server

Sage 200c Professional is not supported when SQL server is installed on a Domain controller.

n SQL server must support TLS 1.2.

n SQL server must be running in Mixed Mode (SQL Server and Windows Authentication mode).

n The Server Collation for SQL server must be set to Latin1_General_CI_AS.
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n We recommend that you use the default accounts set up by the SQL server installation wizard.
(In previous editions of Microsoft SQL Server, we recommended running SQL Server as Local
System Accounts.)

For Sage 200 BI

n Sage 200 BI is not supported on Workgroup editions of SQL server. This is because Business
Intelligence requires Analysis Services.

n Microsoft SQL Server and Analysis Services must be installed on the same machine with the
same instance name.

Web browser support

Web browsers
Desktop
App

Web
App

Microsoft Internet Explorer v10 or Edge on x86 and x64 based PCs - supported
on Server 2012 only

Microsoft Internet Explorer v11 or Edge on x86 and x64 based PCs

Microsoft Internet Explorer v11 or Edge on Microsoft Windows 8.1 tablets
running Windows 8 Professional and Enterprise Editions

Safari on Apple iPad running iOS v10

Google Chrome on x86 and x64 based PCs and 10", 7" and 6" Android devices

Note: Other devices and browsers may be compatible but have not been tested.

Browser settings
When accessing workspaces in the desktop app or from the web app, you may be asked to login.
If you don't wish to be prompted each time, you can set your browser to always use your login
credentials:
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Browser Settings

Internet
Explorer

We recommend that you set this for your local intranet zone, however you may
choose to set Trusted Sites instead depending on your domain or local security
policies.

n Local Intranet zone

a. Open: Internet Options > Security> Custom Level

b. Set user User Authentication > Logon to Automatic Logon with current user
name and password.

n Trusted Sites

a. Open Internet Options > Security > Trusted Sites > Sites.

b. Add the SelfService server URL e.g. https://<server_name>.

c. Open Internet Options > Security > Trusted Sites > Custom Level.

d. Set User Authentication > Logon to Automatic Logon with current user
name and password.

Chrome
- Self
Service
website
only

Set User Authentication > Logon to Automatic Logon with current user name and
password.

Enter the following from the Command prompt:

n For 32-bit operating systems:

"C:\Program Files\Google\Chrome\Application\chrome.exe" -auth-server-
whitelist="localhost, <machine fully qualified domain name>". For example:
"C:\Program Files\Google\Chrome\Application\chrome.exe" -auth-server-
whitelist=localhost, sagesvr01.mydomain.com"

n For 64-bit operating systems:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -auth-
server-whitelist="localhost, <machine fully qualified domain name>". For
example: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -
auth-server-whitelist=localhost, sagesvr01.mydomain.com"

When viewing excel reports in Internet Explorer, you may see this error 'Unable to download
viewreport from [server name]. To resolve this make sure that you have not set the option Do
not save encrypted pages to disk in the Internet Explorer settings.

16
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Microsoft Office
2013
SP1 1

2016 1 Office 365 2

Functions 32-
bit

64-
bit

32-
bit

64-
bit

Desktop
Apps

Online
App

Excel Reporting (new)

Send to Excel (from workspaces and lists)

Opening Attachments

Send Email (not from Report Designer)

Report Designer - output to email

Sage Contact 3 3

Sage 200 BI

1 2013 and 2016 - Standard, Home and Business, Small Business Premium, Professional Plus, and
Enterprise Editions.
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2 Office 365 - Small Business Premium, Professional Plus and Enterprise Editions. Home and
Personal editions are not supported.

3 Sage Contact can only be used with an Office 365 Business Premium or Enterprise (E1, E3 or E5)
subscription.

Note: Office 365 has only been tested with Office 2016 Apps.
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Checking the prerequisites
Before you install Sage 200c, you must make sure the required prerequisites are installed on your
system. You must also make sure that your installations of Microsoft SQL Server and Microsoft
Internet Information Services (IIS) have the required settings.

Using the prerequisite tool
We have provided a tool which to help you check that the required prerequisites are installed on
your server. Use this tool to check the following:

 The server machine name starts with a letter, end with a letter or digit, and have as interior
characters only letters, digits, and hyphens.

For more information about Domain name rules, see section 2.3.1 of the following
article:www.faqs.org/rfcs/rfc1035.htm

 Windows Identity Foundation is installed. This can be added as feature.

 Microsoft .NET Framework version 4.5.2 (or later) is installed.

Note: This may already be included if you have installed a later version of .NET Framework.
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2 | Before you start

 .NET Framework 4.5 (or later) Features with HTTP Activation.

 IIS v8 or higher installed, with the following settings.

Common HTTP Features Default Document

Directory Browsing

HTTP Errors

HTTP Redirection

Static Content

Application Development .NET Extensibility 4.5 (or later)

ASP

ASP .NET 4.5 (or later)

ISAPI Extensions

ISAPI Filters

Security Request Filtering

Windows Authentication

Management Tools IIS Management Console

Management Tools > IIS 6 Management Compatibility IIS 6 WMI Compatibility

IIS 6 Metabase compatibility

Run the prerequisite tool
1. Open the Prerequisite check tool folder on the ISO.

2. Double - click the PreRequisiteCheckTool.exe.

3. Click Start.

20
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4. The results will show which prerequisites are installed.

Additional requirements (not checked by
the tool)
n All machines must have regional and language settings set to either English (UK) or English
(Ireland) only.

n Your domain controller must not be set to Read Only.

n All machines must have a c:\ drive although Sage 200c can be installed and run from a drive
other than c:\.

n Microsoft SQL Server:

l SQL server must support TLS 1.2.

l Must be running in Mixed Mode (SQL Server and Windows Authentication mode).

l The Server Collation for SQL server must be set to Latin1_General_CI_AS.

l If you're using Business Intelligence, SQL Server and Analysis Services must be installed on
the same machine with the same instance name.
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Prerequisites for the client
n All machine names must start with a letter, end with a letter or digit, and have as interior

characters only letters, digits, and hyphens.

n All machines must have regional and language settings set to either English (UK) or English
(Ireland) only.

n All machines must have a c:\ drive although Sage 200c can be installed and run from a drive
other than c:\.

n Microsoft .NET Framework version 4.5.2must be installed.

Note: Even if you have later versions of .NET Framework installed, you will still need to
ensure that your version of .NET includes version 4.5.2. For example, .NET Framework 4.6
and 4.7 should include .NET 4.5.2. For details on how to check this, we suggest that you
consult the Microsoft support site or your Microsoft professional.

n Microsoft .NET Framework version 3.5 is also installed, if you are using Sage 200 BI.

22
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Security and firewall settings
Sage 200c Professional uses a combination of Windows security and SSL certificates to secure
communications between the Sage 200c server and client machines.

Windows File Permissions
The Sage 200c client can be installed to any location on a client machine. To find the Sage 200c
server, the client looks for a file called \\server name\Sage.

In the final step of installation process, the permissions of this folder share are changed as
follows:

Domain
When deployed in an Active Directory Domain environment, access to the central Sage file share
(e.g. c:\Sage) and associated files and subdirectories is restricted to the Sage 200 user and admin
groups.

Note: All domain controllers on the same domain as Sage 200c need to be accessible and
writeable.

Workgroup
When deployed in a Windows workgroup environment, the central Sage file share (e.g. c:\Sage)
and associated files and subdirectories have their permissions set to Everyone | FullControl. We
recommend that you set the Share and Security permissions as follows:

n Set the Share permissions to FullControl/Change/Read for these users:

l Sage 200 Administrators group

l Sage 200 Users group

l Sage 200 Services user

l Sage 200 Secured Services user

n Set the Folder Security toModify/Read&Execute/ListFolderContents/Read/Write for these
users:

l Sage 200 Administrators group

l Sage 200 Users group

l Sage 200 Secured Services user
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Note: Once you have installed Sage 200c, restart the machine before you access System
Administration. This is so the security permissions are set correctly.

Already have a shared Sage folder on your server?
If you already have a folder share called Sage on your server, then the permissions for this folder
will be changed as part of the Sage 200c client installation. You can:

1. Change the name of the share for the existing folder.

2. Install Sage 200c to the existing folder if you're happy with permissions.

Firewall Settings
Sage 200c runs a variety of programs and services that can be affected by security firewall
settings. The following table details the ports that need to be opened in order for Sage 200c to
function correctly.

Server Port Details

Database Server (Default SQL Instance) TCP Port 1433 Default SQL Instance

Database Server (Named SQL instance) UDP Port 1434 Named SQL Instance

File Server TCP Port 139 File & Print Sharing

TCP Port 445 File & Print Sharing

TCP Port 137 File & Print Sharing

TCP Port 138 File & Print Sharing

TCP Port 10443 HTTPS

Sage 200 Self Service TCP Port 10444 HTTPS

Sage 200 CRM Server TCP Port 80 HTTP

TCP Port 443* HTTPS

*You will need to open port 443 on your server machine, and grant permission for
https://licensing.services.sage.com and www.google.com. Google needs to be allowed as
when it checks the licence, it pings Google to ensure there is an internet connection prior to
going to the licensing server.

The following ports are required for Sage 200 BI:

Server Port Details

Database Server (Default SQL Instance) TCP Port 2383 SQL Analysis Services
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Server Port Details

Database Server (Named SQL Instance)* TCP Port 2382 SQL Analysis Services

UDP Port 1434 SQL Browser Service

* For more information see, msdn.microsoft.com/en-us/library/ms174937.aspx#bkmk_named.

Additional firewall settings if you have a named SQL instance or
dynamic ports
Follow the steps below if you have named SQL instance or are using dynamic ports:

1. Find the port number:

a. Open Start > All Programs > Microsoft SQL Server version > Configuration Tools >
SQL Server Configuration Manager.

b. Select SQL Server Network Configuration > Protocols for <your instance Name>.

c. Right-click TCP/IP and select Properties.

d. Select the IP Addresses tab and scroll down to the IPAll group.

e. The current port is the TCP Dynamic Ports number.

2. Set your Firewall to exclude this port number.
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Minimum specifications for
client and server machines
These are theminimum specifications for each client and server machine in a Sage 200c
Professional deployment. Users with large databases or high numbers of concurrent users will
require higher specifications.

Due to the wide variation of companies that use Sage 200c, it is not possible to give exact
specifications for each system. Factors such as the concurrent number of users, size of the
database and estimated growth should all be taken into consideration when sizing a server.

When tasks are processed, CPU and memory resources are used on both the client and the
server. Therefore, the specification of both machines will affect the overall performance of the
system.

To make sure Sage 200c displays correctly:

n Check that your screen Resolution is set to the recommended setting for your display.

To check this, open Control Panel > Appearance and Personalization > Display >
Screen Resolution.

n Check that your text size is set to 100%.

To check this, open Control Panel > Appearance and Personalization > Display, and
ensure that the size is set to Smaller - 100%.

Processor Disk Memory Network

Sage 200c Server

Sage 200c Server with
Microsoft SQL Server

Dual-core
2.6GHz or
equivalent

7,200 rpm SATA with 4GB disk
space after SQL Server is
installed.

4GB Gigabit
Ethernet

Sage 200c Client

Client

Dual Core
1.6GHz or
equivalent

7,200 rpm SATA with 500MB disk
space required.

2GB Gigabit
Ethernet
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Application pools and website
bindings
Sage 200c automatically creates the following application pools, websites and bindings. We
recommend that you do not change these settings:

Website Application
Pool

Binding Path

Sage200AppServices Sage 200
Services

:10080
(http)

:10443
(https)

C:\inetpub\Sage 200 App
Services

Sage200Services

(Virtual directory under Sage 200
Application services)

Sage 200
Services

n/a C:\inetpub\Sage 200 App
Services\Sage200Services

Sage200SecuredServices (Virtual
directory under Sage 200 Application
services)

Sage 200
Secured
Services

n/a C:\inetpub\Sage 200 App
Services\Sage200SeuredServices

Sage 200 Self Service Sage 200 Self
Service

:10082
(http)

:10444
(https)

C:\inetpub\Sage 200 Self Service

If you have an application that already uses the ports listed above you must manually install the
Sage 200c pre-requisites first. Then you must install Sage 200c from a command line using the
following parameters:

For example if d:\ is your DVD drive and ports 11443,and 11444 are you desired ports:

Msiexec.exe /i "d:\sage200.msi" SAGE200ADMINWEBSITEPORT=11443

SAGE200SELFSERVICEWEBSITEPORT=11444

Take care when assigning port numbers as many port numbers are already assigned to other
Windows services or applications. The following table shows the names of the SSL Certificates
bound to these ports:

Binding Certificate

:10443 (https) Sage 200 Application Services SSL Certificate_wixCert_1
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Binding Certificate

:10444 (https) Sage 200 Self Service SSL Certificate_wixCert_1

By default, the Sage 200 Self Serviceweb site is only accessible from your internal network. This
is because the SSL certificates used to secure these sites are based on the machine name and are
not accessible externally. Additional configuration is required to make the site accessible
externally.

For more information, see Install the web app (self service) on an external facing web server on
page 55.
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Install Sage 200c Professional
This sections tells you:

n How to install Sage 200c Professional on the server.

n How to set up System Administration.

n How to install the desktop app (client).

n How to install the web app (Self Service).

n How to install an update for Sage 200c Professional.

29
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Before you start installing
There is a new installation process for Sage 200c Professional. Instead of using a single
installer to install the server and client elements, these are now installed separately.

First you install Sage 200c Professional on the server. As part of the server installation, the
client installers are added to a file share: C:\Sage\Installers. At the end of the server
installation links to the file share are added to a web page. You can then send the link to this
web page to the users so that they can install required client elements.

The user installing or upgrading Sage 200c must have permission to write to the root of the
C:\ drive.

If you're upgrading from 2017 Winter Edition onwards, you don't need to uninstall any Sage
200c desktop apps from the server or client machines when upgrading to a new version. The
new version can be installed on top of the old version.

There's no longer a requirement to install any client elements on the server, unless you're
using BI.

The components for e-banking and the nominal link to payroll will need to be installed
separately when required. This can be done from the desktop app.
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Order of installation
1. Sage 200 server.

2. System Administration.

3. Desktop app (client).

4. Additional installers:

l BI client and admin tool - required if you're also installing BI.

l CRM form Launcher - only required if you're also integrating with CRM.

l Self service - required if you want to access the web app from outside your network.

l Ebanking component.

l Nominal link.

l API - required if you want to use 3rd party applications that access your data via the Sage
200 API.

What access rights are required to install the client?
'Click Once' installers deploy the application into a user's individual profile. No specific
administrator rights are required to install the client, and the setup should be run within the user
context. The first time a non-admin user runs the installer, and opens Sage 200c, they may be
prompted to enter Administrator credentials. This is required to install client pre-requisites (C++
Redistributables), certificates and fonts.

You can no longer use 'Run as Administrator' when installing the client. Using this option to run
in the Administrator context will install the client in the administrator user profile, and the non-
admin user running the installer won't be able to access it.

Installing on Windows 7 without local admin rights
If you're installing the client on a Windows 7 PC where the user does not have local administrator
access, we recommend that the UAC is set to the default level. Turning UAC on in Windows 7
allows our installer to elevate privileges, to admin level, for components that require it (pre-
requisites, certificates and fonts).

If you don't do this, you may experience problems installing pre-requisites and see the following
error when the user tries to access Sage 200c: "Communication error: Could not establish trust
relationship".

To resolve this, just change the UAC to default level and restart the PC.
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What if I'm upgrading from an earlier
version?

Install a new update for Sage 200c Professional
n If you're already using Sage 200c Professional and want to install a new update, you only need

to install Sage 200c on your server. The desktop apps are now installed using 'Click Once'
technology. Once a new version is installed on the server, the desktop apps are automatically
updated the next time a user opens them. :

n If you're upgrading from 2017 Winter Edition onwards, you don't need to uninstall any Sage
200c desktop apps from the server or client machines when upgrading to a new version. The
new version can be installed on top of the old version.

If you're upgrading from 2017 Summer Edition, we recommend that you uninstall Sage 200c
before you install an update.

See Install an update for Sage 200c Professional on page 59.

Upgrading from Sage 200 Extra 2016 or earlier
n You'll still need to uninstall your existing version from all server and client machines.
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Create Windows user accounts
and groups
In Sage 200c Professional, users access the desktop app and System Administration using their
Windows User account log on details. Sage 200c Professional also uses additional Windows User
accounts to access the Sage 200 services.

Before you install Sage 200c Professional, set up the following groups and users in Active
Directory or, if you're using Workgroups, set them up as local groups and users.

Windows user groups
Before installing Sage 200c, you must either choose an existing windows group or create new
groups for the following:

Note: Any pre- windows 2000 domain names need to be the same as Active Directory names.

Note: If you are creating new groups, Active Directory requires that certain characters used
in the distinguished name must be escaped with a backslash "\" character, such as: \ # + < >
; " =

Sage 200 Administrators Group
Must include all users who also need to access System Administration. These users will also be
able to access the desktop app and web app (self service).

You cannot use the Domain Administrators group as the Sage 200 Administrator group, as this
sets up the file share permissions incorrectly.

Sage 200 Users Group
Must include all users who will be accessing the desktop app or web app.

Windows users
Before installing make sure you create the following additional Windows user accounts in Active
Directory. These are used to access the services used by Sage 200c.

33



Sage 200c Professional

Sage 200 Services user
1. Enter a password for the user account and set it to Password never expires. It does not

require any other special permissions.

2. Add this user to the Sage 200 Administrators group.

3. Make a note of the account's name and password as you need to enter these as part of the
installation process.

Sage 200 Secured Services user
1. Enter a password for the user account and set it to Password never expires. It does not

require any other special permissions.

2. Add this account to any of your domain user groups.

If you will be using Sage Bank Feeds, make sure you also add this account to the Sage 200
Administrators group.

3. Make a note of the account's name and password as you need to enter these as part of the
installation process.

FAQs
What if the password has changed?
If the password is changed for either of the Sage 200 Service accounts, you must update the
passwords in these application pools:

Application Pool User

Sage 200 Secured Services S200SecuredServices

Sage 200 Self Service S200Services

Sage 200 Services S200Services

I get the following communication error: The HTTP service
located at xxx is too busy
This indicates that the password has been changed for the Sage 200 Services or Secured Services
users. Update the password in all the application pools listed above.

Communication Error: The HTTP service located at
https://yourservername:10443/Sage200Services/AuthenticationService.svc is too busy.

34



3 | Install Sage 200c Professional

What if need additional users?
You can add the required windows user accounts to the user groups after Sage 200c has been
installed. Access to specific modules and features is controlled in System Administration.

For more information on where to set up users using Windows Active Directory, or using
Windows user groups, refer to your operating system help, as the process may involve different
steps in different operating systems.

I get an error when I try to download bank feeds
If you are using Sage Bank Feeds, make sure that the Sage 200 Secured Services user is included
in the Sage 200 Administrators group.

If you change the Sage 200 Secured Services user's group, remember to update the users list in
System Administration.
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Install Sage 200c Professional
on the server
1. Run the Setup.exe file.

Tip: Don't forget to Run as Administrator, if you've enabled Microsoft User Account
Control.

2. Read and accept the terms and conditions of the licence agreement.

Sage 200 terms and conditions

3. If this site is also using BI and / or Manufacturing, make you select these here.

4. Enter the location on your server for the Logon Folder.

This where shared files and reports are stored.

Tip: Make sure there are no spaces in the location as this will cause the installation to fail.
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5. Enter the names of the Windows User groups that the users belong to. Members of the Sage
200 Administrators group can also access System Administration.

Note: You cannot use the Windows Domain Administrators group as the Sage 200
Administrator group, as this sets up the file share permissions incorrectly.

If you want to check the Active Directory groups available on this network, you can use the
InstallationHelper tool. This can be found on the ISO.

6. Enter the user names and passwords for the windows user accounts that you've set up to run
Sage 200 Services and Sage 200 Secured Services.

7. Click Install.
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8. Once the installation is complete, you'll see a final page with a link to a web page that contains
links to all the client installers.

Simply click Copy link to clipboard and send to it to anyone who needs to install the client on
their PC. They just need to open the web page to install the required components.

If you're installing BI or want to install any of the client components on the server, select Show
Additional Sage 200 Components page.

Tip: If you lose the link to this page, you can find the .exe files for the installers in
C:\Sage\Installers. The web page address is
http://<servername>:10080/Sage200Content/sage200installers.html

9. Click Finish when the installation is complete.
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Install and set up System
Administration
Before you can access Sage 200c, you must use the System Administration tool to set up a
configuration database, company databases, users and roles.

System Administration must be installed on at least one PC. This can be a client PC or the server.
Make sure that the user is a member of the Sage 200 Administrators group.

Install
1. Click the Sage 200 Administration section. This opens the Sage Installers folder on your PC.

2. To download the installation package, click on the Setup.exe file shown.

3. When the download has completed, click Install.

4. The first time that you open System Administration, you may need to enter credentials for a
Windows administrator account. This will only be required once.

Note: You can only access System Administration if you have been added to the Sage 200
Administrators group in Windows.

For detailed information on the options available in the System Administration tool, please see
the System Administration help: Sage 200 help
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Create / update the
configuration database
1. ClickOK to the message "A Sage 200 SQL configuration database could not be found."

2. Enter or browse for the correct SQL server and enter user details to connect to it.

3. For new installs, enter a name for the configuration database such as Sage200Configuration.
If you're upgrading, enter or browse for your existing configuration database.

4. Click Create or Update.

Note: A number of processes run during this process, so it can take some time.

If another Sage 200 Administration user is also attempting to create the configuration
database at the same time, you will see the message:

Check with any other Administration users of Sage 200 and try again.
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Manage users
When you have created the configuration database, the Manage User Lists window appears.
This displays all the Windows User accounts that are members of the Sage 200 Users and Sage
200 Administrators groups that were specified during the installation.

This creates a user account in System Administration for each Windows user shown in the left
hand list. The first time you install Sage 200c, all the Windows User accounts will have a status of
New. If you're upgrading, only users who've been added to the Administrators and Users groups
are shown asNew.

n ClickOK to create new user accounts in System Administration and link them to allNew
windows accounts listed.

n Now you can link these users to roles and companies.

FAQs

Upgrading from v2011?
You can link your existing users with the windows users accounts. This way you don't lose any of
the information that's already set up.

1. To link a Windows User account to an existing Sage 200 user account, select the Windows
User in the left hand list and then select the required Sage 200 user account from the right
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hand list. The status will show as Linked.

Note: To change the user links, select the user and then select Unlink.

2. To create a new Sage 200 user account, do not link the Windows User account. A new Sage
200 user account is created for any Windows User accounts with a status ofNew.

3. ClickOK.

What if my Windows user accounts change?
You can also use this screen, at any time, to update your Sage 200c user list.

For example, if you add or delete windows users in future, this screen is displayed when you open
System Administration.

Tip: Don't forget, when you remove a user from the Sage 200 Administrators or Sage 200
Users groups, that user will still be able to access Sage 200 until you refresh this list.
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Activate your licence
You must register Sage 200c and obtain a licence before you can use it. Once registered, you
activate your licence using the Sage Licensing service. You can access this via the internet. If
you're not currently connected to the internet, you can obtain a 30 day offline licence via email.

You activate your licence using your account number and serial number.

Register via the Internet

1. Enter your customer Account Number.

2. Enter your product Serial Number.

3. ClickOK.

The system automatically contacts Sage for a valid licence. This licence enables you to use
Sage 200.

Once the licence has been activated, the core components are automatically installed.

If you see the following message, you may need to register offline:

Unable to communicate with the Sage Licensing Service. Please contact your company
administrator or business partner if this problem persists.

You can now access System Administration and set up your companies, users and roles.

Using a proxy server on a client machine
If you're using a proxy server on your client machine, System Administration may not be able to
connect to the licence server.
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To resolve this, add the following to the web.config file.

1. Open the web.config file: C:\inetpub\Sage 200 App
Services\Sage200SecuredServices\web.config

2. Add the following after the </system.web> section and enter your IP address for the
proxyaddress.

<!-- Proxy settings -->

<system.net>

<defaultProxy enabled="true"useDefaultCredentials="true">

<proxy

autoDetect

="false"

bypassonlocal

="false"

proxyaddress

="http://10.0.1.254:8080"usesystemdefault="false" />

<!--<add your IP address and port number in the following

way: proxy autoDetect="false" bypassonlocal="false"

proxyaddress="<MyProxyIP>:<Port>" usesystemdefault="false"

/>-->

</defaultProxy>

</system.net>

To register offline
This generates a licence request file which you send to Business Partner Services via email.
Business Partner Services will email you a licence entitlement file which you import into System
Administration to register Sage 200c.

Your offline licence is valid for 30 days. This is to give you a window in which to access to the
licence server online. If you can't access the licence server via the internet within this 30 days, you
will need to generate a new offline activation. In this case , you 'll see the following message: The
Sage Licence will expire in 7 days because the entitlement server has been unavailable for 28
days.

Request an offline licence
1. When the Licence window appears, click Cancel. The Core Components are installed.

2. Right-click Licence and select Generate Licence Request.
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3. Enter your Account Number and Serial Number and clickGenerate Request.

This creates a licence file in XML format which you send to Business Partner Services.

4. Browse to where you want to save the XML file.

5. Enter a File name and click Save.

6. Email this XML file to Business Partner Services at BPServices@sage.com

Activate your offline licence
You will receive an email from Business Partner Services with your refreshed licence attached.
This has the extension .ent (Entitlement files). Save this file to your PC.

1. Open Licence in System Administration.

2. Right-click and select Import Licence File.

3. Click Import Licence File and browse to where you saved the entitlement (.ent) file.

4. Select the file and clickOpen.

Your licence is activated.

When you implement offline licensing, the Sage 200c application will still intermittently
attempt to access the Sage licensing server. This process will eventually timeout and the
application will continue to work provided that the licence you have on your server is valid.

If you are experiencing intermittent delays starting the application, then reducing the
timeout period could help. To reduce the timeout period:

IMPORTANT: We recommend that you take a backup copy of any config file before
making any changes.

1. Ensure all users are logged out. Then:

 c:\inetpub\Sage 200 App Services\Sage200SecuredServices\web.config.

3. Edit the SlsServiceTimeOut key:

Old value: <add key="SlsServiceTimeOut" value="30000"/>

New value: <add key="SlsServiceTimeOut" value="1000"/>

4. Save the file.

5. Reset IIS.
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Create or update your company
database
You can use System Administration to create new SQL databases for your Sage 200c companies.
If you're upgrading to a new version, don't forget to update all company databases as well.

If you have an existing company database, you can add the company in the System
Administration tool. The database must be attached to your SQL server.

Enter the following:

n Company Name - This must be at least one character in length and unique. Do not use the
word Configuration in the company name.

n Parent company - This is only required if you're using consolidation.

n Attachments - This must be a UNC path. We recommend that you use a different
Attachments folder for different companies.

n SQL server settings - You must have the appropriate permissions to access the server.

n Banner settings - Make it easier to see which company you are working with by using a
company colour.
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Set up user accounts, roles and
features
Before your users can access the desktop app, you must set up each user account. You must
choose which companies each user can access and assign at least one role.

The role controls which menu options and workspaces a user can access in Sage 200c. Each
menu option in the desktop app or web app is listed as a Feature in System Administration. To
make a menu option available to your users, you must authorise the relevant features for each
role.

Tip: Don't forget, if you're upgrading, you'll need to authorise any new features included in
the upgrade for the relevant roles, before users can access them.

For Sage 200 v2011 and below, you would access spooled reports through an option on the
Role. This is now controlled in Features. The Print Spooling features need to be authorised for
each relevant role.

Set up roles
1. Right click Roles and chooseAdd new Role.

2. Authorise features for each role. Right-click the role and select Features.

Don't forget, if you've upgrade, you'll need to add any new features included in the upgrade to
your roles.

Note: You must authorise the System Administration Services feature for all roles that
need to log on to the desktop app.

Set the user properties
 Users
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1. Right click theUser Name and click Properties.

2. General tab.

User Enabled Makes the user account active.

Can Edit Menus For
Roles

Allows the user to edit menus in Sage 200.

Can Edit
Workspaces

Sage 200c Professional only - Allows the user to access theWorkspace
Designer to edit workspaces.

Receive
Notifications by
Email

Allows the user to receive email messages when purchase orders
require authorisation.

In Product Survey
Enabled.

Allows the user to receive the in product survey.

This is selected by default.

Note: The In Product Surveymust be Enabled. For more
information see the System Administration help.

Is Web user Allows user to access the web app (self service)

3. User details tab.

Enter the user's email address and other personal information. You need to add the email
address if the user will access 3rd party add-ons via the API.

4. Member of tab.

Choose the role(s) the user is a member of. This determines the screens they can access in the
desktop app.

5. Company Access tab.

Use this to assign the relevant companies to the user.

6. API tab.

Use this to enable additional authentication for a user, using Sage ID or Azure Active
Directory (AD). Set up authentication for a user when they will:

l Use third party apps which access your data via the Sage 200 API.

l Use Sage connected apps such as the Sage Contact app and Pegg chatbot.

7. ClickOK.

For more information about user accounts, role, and features, see the System Administration
help: desktophelp.sage.co.uk/sage200/professional/help.htm#SAA/Overview.htm.

48

http://desktophelp.sage.co.uk/sage200/professional/help.htm#SAA/Overview.htm


3 | Install Sage 200c Professional

Install the desktop app (client)
Once you've installed Sage 200c on the server, each user can install the required client
components on their own machines.

What access rights are required to install the client?
'Click Once' installers deploy the application into a user's individual profile. No specific
administrator rights are required to install the client, and the setup should be run within the user
context. The first time a non-admin user runs the installer, and opens Sage 200c, they may be
prompted to enter Administrator credentials. This is required to install client pre-requisites (C++
Redistributables), certificates and fonts.

You can no longer use 'Run as Administrator' when installing the client. Using this option to run
in the Administrator context will install the client in the administrator user profile, and the non-
admin user running the installer won't be able to access it.

Installing on Windows 7 without local admin rights
If you're installing the client on a Windows 7 PC where the user does not have local administrator
access, we recommend that the UAC is set to the default level. Turning UAC on in Windows 7
allows our installer to elevate privileges, to admin level, for components that require it (pre-
requisites, certificates and fonts).

If you don't do this, you may experience problems installing pre-requisites and see the following
error when the user tries to access Sage 200c: "Communication error: Could not establish trust
relationship".

To resolve this, just change the UAC to default level and restart the PC.

How to install the desktop app
Note: If Microsoft .NET version 4.5.2 isn't already present on any client machines, it's installed
as part of the client installation process.
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1. Click on the link that has been sent to you to open the Sage 200 Installation page.

2. Click the Sage 200 Client section. This opens the Sage Installers folder on your PC.

Note: If you're using Manufacturing, this is called Sage 200 MFG client.

3. To download the installation package, click on the Setup.exe file.

50



3 | Install Sage 200c Professional

4. When the download has completed, click Install.
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Set up the web app (self
service)
The web app allows to you access Sage 200c data, run reports and carry out certain tasks from a
web browser; such as enter and authorise purchase requisitions, authorise purchase orders,
enter and authorise timesheets and expenses (WTE).

Only users who are set asWeb users in System Administration can access the web app. User can
be desktop and web app users or just have access to the web app. You can have up to 100
concurrent web users.

Once you have installed Sage 200c, the web app (self service website) can be accessed on your
internal network from any machine with a compatible internet browser.

Before user can access the web app ( self service website), the correct SSL certificates need to be
installed an any machines that will connect to web app.

n For machines that have the desktop app installed, the SSL certificates are installed
automatically.

n For other machines, then you must install the required SSL certificates

What if I want to access the web app outside of my network?
If you want to access the Self Service website externally over the internet, additional
configuration is required. This is because the SSL certificates that are installed with Sage 200c are
for internal use only and are based on the machine name. They are not externally addressable. To
use the web app externally over the internet, see Install the web app (self service) on an external
facing web server on page 55.
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Install the SSL certificates for
the web app (self service
website)
You must install the SSL certificate on each client machine that will access the web app and
doesn't have the desktop app installed. You can do this on individual machines or via a group
policy.

Install on an individual client machine
Complete the following steps . You must be logged on to the machine as an administrator.

1. Choose Start > Run. Enter the UNC path to the Sage folder on your server. For example
\\<Machine_Name>\Sage.

2. Select Logon > SSLCertificate.

3. Right-click the S200SSServerRootCA.cer file and choose Install Certificate.

TheCertificate Import Wizard appears. ClickNext.

4. Select Place all certificates in the following store.

5. Click Browse. The Select Certificate Storewindow appears.

6. Select Show physical stores.

7. Select Trusted Root Certification Authorities> Local Computer. ClickOK.

8. ClickNext and Finish.

You can now browse to the Self Service web site over a secure connection.

Add certificates via a Group Policy
If you have several client machines that will use the web app, you can deploy the Sage 200 SSL
certificates via Microsoft Active Directory Group Policy. This means you do not have to install the
certificate individually on each client machine.

1. Copy the contents of the following folder from your Sage 200 file server to a new folder on
your domain controller.

C:\Sage\Logon\SSL Certificate.

2. On the domain controller, choose Start > Administrative Tools > Group Policy
Management.
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3. Select Group Policy Management > Forest > Domains for the domain containing the Default
Domain Policy GPO that you want to edit.

4. Select Group Policy Objects.

5. Right-click Default Domain Policy GPO, and click Edit.

6. In the Group Policy Management Console, select Computer Configuration > Windows
Settings > Security Settings. Click Public Key Policies.

7. Right-click Trusted Root Certification Authorities.

8. To import the certificates, click Import .ClickNext.

9. Browse to the location of the certificates you copied in step 1. Click Next.

10. Make sure theCertificate Store path is set to Trusted Root Certificates Authorities. Click
Next.

11. Click Finish and OK to complete the import.

For further information on deploying certificates, see technet.microsoft.com/en-
us/library/cc754841.aspx.

Set up users to access the web app (Self Service website)
A user can only access the web app if they are designated as aWeb user in their user properties
in System Administration. You can have up to 100 concurrent web users.

1. For each user, open Users > Properties.

2. Select Is Web User.

Reset IIS
You must reset IIS before you can access timesheets and expenses from a web browser.

If IIS is not reset you'll see and internal server error when accessing these pages.

Access the website
Once set up, each user can access the website by entering the address in a web browser. This
should include the server name and port number of the website. By default, the port number is
10444.

For example: https://<Server_Name>:10444/Sage200SelfService.

Note: There is a 20MB limit on the size of an attachment that you can view via a workspace
viewed in a web browser. This affects the following workspaces: Bank Account Enquiry,
Customer Account Enquiry, Nominal Account Enquiry, Stock Status Enquiry and Supplier
Account Enquiry. There is no limit for viewing attachments via a workspace in the desktop
app.
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Install the web app (self service)
on an external facing web server
Sage 200c can be set up so that the web app (Self Service website) can be accessed externally
from mobile devices and machines that are not joined to your domain. It is good practice to
separate this service out onto it's own server so that if your network is compromised your data is
protected behind a separate firewall for your SQL server.

In order to do this you will need:

n An external facing web server with internet access to host the Self Service web site.

n A commercially available SSL Certificate to verify your domain and secure the web site.

n A registered domain name to direct traffic to the web site.

We recommend that you purchase any required domain names and SSL certificates and
configure them to point to your external facing web server. Speak to your service provider for
advice on how to do this.

Before you install the Self Service application on an external facing server, you must have
installed and fully configured Sage 200c on the Sage 200 server and you must be able to log into
Sage 200c.

Once configured, your Sage 200c deployment will look like this:

Prerequisites
The machine hosting the external facing Self Service web site must be joined to the same domain
as the server hosting Sage 200c and have the following installed:

n Microsoft .NET Framework version 4.5.2 (or later) is installed.

Note: This may already be included if you have installed a later version of .NET Framework.
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n Windows Identity Foundation. This can be added as a feature.

n .NET Framework 4.5 (or later) Features with HTTP activation.

n Microsoft Internet Information Services (IIS) v8 or higher with the following settings.

Common HTTP Features Default Document

Directory Browsing

HTTP Errors

HTTP Redirection

Static Content

Application Development .NET Extensibility 4.5 (or later)

ASP

ASP .NET 4.5 (or later)

ISAPI Extensions

ISAPI Filters

Security Request Filtering

Windows Authentication

Management Tools IIS Management Console

Management Tools > IIS 6 Management Compatibility IIS 6 WMI Compatibility

IIS 6 Metabase compatibility

n If using Windows Server 2016 Standard, you may also need to install additional roles and
features for .NET 3.5.

See Install .NET 3.5 roles and features for Sage 200 Self Service on page 75.

Install the Self Service web site
Follow these instructions to install the Self Service web site on your external server.

1. Open the shared Sage folder on the server.

2. Select Installers > Sage 200 Self Service.

3. Run the Sage200SelfService.exe file. This opens the installation wizard.

Note: If you're installing Self Service on Windows Server 2016 Standard and the installer
displays an error message that "ASP.NET 4.5 must be enabled on the application server to
continue", see Install .NET 3.5 roles and features for Sage 200 Self Service on page 75.

4. Accept the Licence Agreement and clickNext.
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5. The path to the Logon directory on your Sage 200 Server machine is displayed. Make sure
that the path is correct and clickNext.

6. Check the name of the windows account that you set up to run the Sage 200 Services. Enter
the password for this account. ClickNext.

7. Click Install to start the installation.

Secure the Self Service web site with your SSL certificate
Once you have installed the Self Service web site on your external server machine, you need to
amend the web site bindings in IIS to use the external SSL certificate and set up firewall rules on
both your Sage servers.

1. Open Internet Information Services (IIS) Manager.

2. Expand the list of websites and choose Sage 200 Self Service.

3. Right-click and choose Edit Bindings.

4. ChooseAdd and change the type to https.

5. From the SSL certificate drop-down menu, choose your external SSL certificate.

Note: This is not the Sage 200 Self Service SSL Certificate.

6. ClickOK.

Note: You may see a message informing you that another site is using the same HTTPS
binding. Click Yes to apply the binding to this site.

7. ClickOK to close the 'Add Bindings' window.

8. Click Close to close the Site Bindings window.

The Sage 200 Self Service web site is now using your external SSL certificate.

Set up your firewall rules
To increase the security of your deployment you must configure the Windows firewall on both of
your Sage servers.

The following table details the ports that need to be opened in order for Sage 200 to function
correctly.

Sage 200 Server (Inbound Rules) TCP Port Sage 200 App Services (Default 10443)

TCP Port Sage 200 Self Service | Internal (Default
10444)

SQL Server (Inbound Rules) TCP Port SQL Server (Default: 1433)

Sage 200 Self Service Server (Inbound
Rules)

TCP Port 443
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Reset IIS
You must reset IIS before you can access timesheets and expenses from a web browser.

If IIS is not reset you'll see and internal server error when accessing these pages.

Test the access to the Self Service web site
1. To access the website, open a browser and enter the following address:

https://<your domain name>/Sage200SelfService

2. Log onto the site using Windows credentials associated with a user with Is Web user
selected.

Note: You may not be able to access this address directly on the external facing web
server but it will be accessible on all other supported machines / devices.
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Install an update for Sage 200c
Professional
Follow these steps if you are already using Sage 200c Professional and want to install a new
update.

Before you install
n See Before you start on page 6 for information on what's new, and any changes to supported

software and prerequisites.

n If you're upgrading from 2017 Winter Edition onwards, you don't need to uninstall any Sage
200c desktop apps from the server or client machines when upgrading to a new version. The
new version can be installed on top of the old version.

If you're upgrading from 2017 Summer Edition, we recommend that you uninstall Sage 200c
before you install an update.

n You only need to install the Sage 200c update on your server. Once a new version is installed
on the server, the Sage 200c desktop apps are automatically updated the next time a user
opens them.

n The user installing or upgrading Sage 200c must have permission to write to the root of the
C:\ drive.

Install an update for Sage 200c Professional
1. On your server, run the Setup.exe file.

Tip: Don't forget to Run as Administrator, if you've enabled Microsoft User Account
Control.

2. Follow the steps in the installation.

l Sage 200c will be installed with the same options that you chose in your previous
installation.

l If you want to change any settings, or need more detailed steps on installing, see Install
Sage 200c Professional on the server on page 36.

l The only information you will need to enter are the passwords for the windows user
accounts that you've set up to run Sage 200 Services and Sage 200 Secured Services.

3. Once the installation is complete, click Finish.
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Once a new version is installed on the server, the Sage 200c app and System Administration
will automatically be updated the next time a user opens them.

Update company and configuration
databases
After you install the update, you will need to update your company and configuration databases
in System Administration.

 System Administration.

1. Update your configuration database.

a. Right-click the Sage 200 SA server (at the top of the navigation area) and select
Properties.

b. In the server properties, click Update.

2. Update your companies.

a. Select Companies, to display your companies.

b. Right-click Companies and select Update all companies.

Note: If you want to update individual companies, right-click the company and select
Properties, then select Update.

Add new features to roles
When you upgrade to a new version, some new functionality will have a corresponding new
feature. As these new features won't be selected for any of your existing roles, users will not yet
have access to the new feature. For any new features, you will need to enable the feature for the
appropriate roles.

 System Administration.

1. Select Roles.

2. Right-click on each role and choose Features.

Select any new features to include in that role.
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Upgrading from Sage 200 v2011

Link Windows user accounts with existing
users
Sage 200c Professional uses Windows User accounts to control access rights in Sage 200c. Users
are still set up in System Administration using roles and features as previously, but are now linked
to Windows user accounts.

When you first open System Administration after upgrading, you can link each existing user in
System Administration with their relevant Windows users account. This way you don't lose any of
the information that's already set up.

1. To link a Windows User account to an existing Sage 200 user account, select the Windows
User in the left hand list and then select the required Sage 200 user account from the right
hand list. The status will show as Linked.

Note: To change the user links, select the user and then select Unlink.

2. To create a new Sage 200 user account, do not link the Windows User account. A new Sage
200 user account is created for any Windows User accounts with a status ofNew.

3. ClickOK.
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Report Designer
Sage 200c Professional uses the latest version of Report Designer. The legacy Report Designer
that was available with Sage 200 2011 is no longer supported.

If you have customised reports that were created using the old version of Report Designer (using
file types of .slt, .sly, .srt, etc.), these must be converted to the new file types (.report, .letter, .layout
, etc.) before you upgrade to Sage 200c Professional.

You can convert your reports and documents to the new file types in two ways:

n If you still have Sage 200 v2011 SP7 installed, open Report Designer from Sage 200 v2011 and
use the File > Import option to update your reports.

n Alternatively, you can use the Legacy Report Conversion Tool, which is included with the
Business Partner Tools (for 2010 and 2011).

Download Business Partner Tools (Sage 200 Extra 2010 and 2011)

How are reports stored?
Reports and documents are also stored in a new location on your server; Sage\Reporting. Within
this folder, reports and documents are also stored in three location levels:

n Sage\reporting\default for the default reports and documents supplied with Sage 200.

n Sage\reporting\custom for reports and documents you have customised.

n Sage\reporting\company\<company name> for reports and documents that you have
customised for a specific company.

Note: For company reports and documents you must create the required folders first.

When a report is run from Sage 200c, the company specific reports and documents are checked
first, then the custom reports and documents and finally the default reports and documents. The
first report located is then used.

Once you have edited or created a report or document, you must save it to a custom or company
folder using the same folder structure and the same name as the default report or document.

What about my custom reports?
As part of the upgrade process, all the default reports, documents, letters etc are added to the
Sage\reporting\default folder and sub folders.

If you have reports and documents that you have previously customised, you must move these
reports and documents to the required folder using the new folder structure.

For more information, see Designing your own reports and documents.
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Upgrading from Sage 200 v2013

Part-reconciled bank transactions
It is not possible to part-reconcile bank transactions in Sage 200 2016 and later versions.

As you can part-reconcile bank transactions in Sage 200 2013 and prior versions, we recommend
that you fully reconcile (or unreconcile) these transactions before you upgrade from Sage 200
2013.

Otherwise, if you upgrade with part-reconciled bank transactions, then you will manually have to
correct these. You can do this by entering a nominal non-vatable payment or receipt to the bank
account, and then reconciling these transactions.
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Install the desktop client app
manually
If you don't want to install the Sage 200c Professional client using the 'Click Once' installer, you
can install the Sage 200c client manually. When you install the Sage 200c client manually, you can
choose the installation folder, as opposed to Sage 200c being installed in the user's profile (using
'Click Once').

For example, you may want to install the Sage 200c client manually if:

n You use a custom installation process for Sage 200c.

n You use a thin client environment (RDS), and want to install the Sage 200c client in a folder
which can be used by more than one user profile.

To install Sage 200c Professional manually
1. Install Sage 200c Professional on the server.

See Install Sage 200c Professional on the server on page 36.

2. Create a folder on your client PC that you will run Sage 200c from, for example Program Files
(x86)\Sage\Sage200.

3. On the server, browse to the Installers folder, for example YourServer\Sage\Installers.

4. Locate the Sage 200 Client installation zip file on the server and unzip it to the folder on your
client PC.

l If you don't use Manufacturing, this file is Sage 200 Client / Sage200Client.zip.

l If you use Manufacturing, this file is Sage 200 MFG Client / Sage200MfgClient.zip.

5. Locate the Sage200CommonAppSettings.config file on your server Installers folder, and
copy this to the same folder on your client PC.

6. To create a shortcut to the Sage 200c application on the client PC, right-click
Sage200Desktop.exe and select Create shortcut.

FAQs
I see a "Logon failed due to unexpected error" message when I run the
client
If you see the error "Logon failed due to unexpected error", then this means the
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Sage200CommonAppSetting.config could not be found.

Make sure that the Sage200CommonAppSetting.config on the server has been copied to the
same folder on the client PC that contains the Sage 200c application files.
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Troubleshooting
MMS user error when updating configuration
database
If you see this error when updating the configuration database, click Test first, then update again.

I get the following error: 'Could not establish trust
relationship for SSL/TLS'
This message occurs when a non-admin user installs the client on a Windows 7 PC and User
Account Control is turned on.

To resolve this:

n Change theUser Account Control on the PC to theDefault level.

n Restart the PC.

'You are not a Sage 200 user' error
This message can be caused by the following:

n System Administration has not been installed on any PC.

n The user has not been assigned to any companies in System Administration.

n IIS has not been reset after installing System Administration.

The desktop icon is missing
This will occur if the desktop app ( client) is installed as the Administrator rather than the user on
the PC.

To resolve this, re-install the desktop app and don't choose Run as Administrator.

I get the error 'The application cannot be started'
When trying to update to the new version of Sage 200, the following message is displayed:
Application cannot be started. Contact the application vendor.
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This message will appear if you are trying to install Sage 200, but you do not have Microsoft .NET
Framework version 4.5.2 (or later) installed.

To resolve this, install Microsoft .NET Framework version 4.5.2 (or later), which is a prerequisite for
the client machine.

I get the following error: 'The HTTP service located at
xxx is too busy'
This indicates that the password has been changed for the Sage 200 Services or Secured Services
users.

To resolve this, update the password in the following application pools:

Application Pool User

Sage 200 Secured Services S200SecuredServices

Sage 200 Self Service S200Services

Sage 200 Services S200Services

Communication Error: The HTTP service located at
https://yourservername:10443/Sage200Services/AuthenticationService.svc is too busy.

BI - Error updating the cubes
You'll see this error if you weren't logged in as the scheduled task user when installing the
desktop app on the server machine.

To resolve this, log onto the server as the windows user for the scheduled task and re-install the
desktop app.
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Sage 50 Payroll crashes when running a report
If you are using Sage 50 Payroll and Sage 200c on the same PC, Sage 50 Payroll can crash when
running a report. See Troubleshooting Sage 50 Payroll with Sage 200c on page 69.

Security warnings when viewing workspaces with
Chrome
If you try to view workspaces with Google Chrome browser v58 or later, you may see a security
warning such as "Your connection is not private".

This occurs when viewing workspaces using the web app, or from the desktop app if you have
chosen to Show Workspaces in Browser.

See Security warning when viewing workspaces with Chrome on page 71.
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Troubleshooting Sage 50 Payroll
with Sage 200c

Sage 50 Payroll crashes when running a
report
If you are using Sage 50 Payroll and Sage 200c on the same PC, Sage 50 Payroll can crash when
running a report.

In some circumstances, Sage 50 Payroll stops responding when launching a report on a PC that
also has Sage 200c installed. This occurs when you install Sage 200c before installing Sage 50
Payroll (version 22), and are logged in to the PC as a user in the Sage 200 Users group.

Note: If Sage 50 Payroll version 22 is installed first, or you're logged into the PC as user in the
Sage 200 Admins group, the Payroll reports should will work fine and reports can be
produced as normal.

Cause
This issue is a result of incorrect permissions on theC:\ProgramData\Sage\Central folder. This
folder is created by whichever application is installed first.

n When Sage 50 Payroll is installed first, the Everyone group has Full control over the folder.
With these permissions, everyone can produce reports from Payroll without a problem

n When Sage 200c is installed first, the Sage 200 Admins and Sage 200 Users groups are
created. The Sage 200 Admins have Full Control over the folder, but Sage 200 Users only
have access to Read + Execute, List folder contents, and Read.

Therefore, those users in the Sage 200 Users group can't run reports from Payroll.

Solution
This should only be required when Sage 50 Payroll is installed after Sage 200c.
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1. Set the permissions on theC:\ProgramData\Sage\Central folder.

a. Select the Everyone group.

b. Give full control permissions by ticking Allow for Full Control.

2. Install Sage Report Designer.

If you have Sage 200c installed on the same PC as other Sage software (such as Sage Payroll
or Sage 50), then you must install Report Designer separately.

This is to make sure that you are using the most recent version of Report Designer.

a. Download the installation file from the Sage support website.

b. Open the file Sage.Central.ReportDesigner.Installer.msi install Report Designer.
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Security warning when viewing
workspaces with Chrome

Issue
If you try to view workspaces with Google Chrome browser v58 or later, you may see a security
warning such as "Your connection is not private".

This occurs with Sage 200c Professional when viewing workspaces using the web app, or from
the desktop app if you have chosen to Show Workspaces in Browser.

Cause
Google Chrome (v58) has introduced more stringent security checks for SSL certificates on
secured websites.
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Solution
If you see this warning when trying to access Sage 200c workspaces from your server, it is safe to
ignore the warning and proceed.

1. Click Advanced.

2. Click Proceed to ....
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TLS requirements for Microsoft
SQL Server
n By default, Sage 200c now requires that your version of Microsoft SQL Server supports TLS
1.2.

Vulnerabilities have been reported against SSL and TLS 1.0 and 1.1, so we recommend that you
use Microsoft SQL Server versions with support for TLS 1.2.

n The security protocols TLS 1.0 and SSL3 will be disabled by default and not used with Sage
200c.

How do I know if SQL Server supports TLS
1.2?
To determine whether your current version of SQL Server already has support for TLS 1.2, or
whether you have to download an update to enable TLS 1.2 support, please see this Microsoft
support article: support.microsoft.com/en-us/help/3135244/tls-1-2-support-for-microsoft-sql-
server

If your version of Microsoft SQL Server does not support TLS 1.2, and you are unable to upgrade
at this time, you can manually configure Sage 200c to use TLS 1.0 or 1.1 instead. See How do I
configure Sage 200 to use TLS 1.0 or 1.1? on page 73.

How do I configure Sage 200 to use TLS 1.0
or 1.1?

We recommend that you upgrade Microsoft SQL Server to support TLS 1.2. But if you cannot
upgrade SQL Server at this time, you can manually configure Sage 200c to use TLS 1.0 or 1.1
instead.

Update Sage 200c client configuration
You will need to update the configuration file on each Sage 200c client PC.
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1. In Windows Explorer, locate the Sage 200c ProgramData folder.

For example, this will usually be something likeC:\ProgramData\Sage\Sage200\20.0.7.0.

The folder name may vary depending on the version number.

2. Open the file Sage200CommonAppSettings.config in a text editor.

3. Locate the <appSettings> section in the file, and insert the following inside
<appSettings>.

a. To use TLS 1.0:

<add key="AllowTLSVersion" value="TLS10"/>

b. To use TLS 1.1:

<add key="AllowTLSVersion" value="TLS11"/>

Note: If you later update your SQL server to support TLS 1.2, then remove the line that you
inserted.

Update Sage 200c server configuration
You will need to update these configuration files on the Sage 200c server PC.

1. Open Internet Information Services (IIS)Manager on the server PC.

2. Locate the Sage 200 App Services site, and open it to view its applications.

3. Update the fileweb.config for each of these sites and applications.

To locate theweb.config file for an application, right-click the application and select Explore.

l Sage 200 App Services > ContractAPI.

l Sage 200 App Services > NativeAPI.

l Sage 200 App Services > Sage200Services.

l Sage 200 Self Service > Sage200SelfService.

4. Open the fileweb.config in a text editor.

5. Locate the <appSettings> section in the file, and insert the following inside
<appSettings>.

a. To use TLS 1.0:

<add key="AllowTLSVersion" value="TLS10"/>

b. To use TLS 1.1:

<add key="AllowTLSVersion" value="TLS11"/>

Note: If you later update your SQL server to support TLS 1.2, then remove the line that you
inserted.
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Install .NET 3.5 roles and
features for Sage 200 Self
Service

Problem
When you run the installer for Sage 200 Self Service on Windows Server 2016 Standard, the
installer fails with the message: ASP.NET 4.5 must be enabled on the application server to
continue.

Why does this happen?
Although Windows Server 2016 Standard has .NET 4.6 installed, this error is actually caused by
missing roles and features for .NET 3.5.

How do I fix this?
To resolve this, you must enable some options for .NET 3.5 in Server Manager.

1. Open Server Manager (in Windows Server 2016).

2. SelectManage > Add Roles And Features.

3. In the roles and features wizard:

l On the Server Roles page, enable these roles:

o Web Server (IIS) > Web Server > Application Development > .NET Extensibility 3.5

o Web Server (IIS) > Web Server > Application Development > .ASP.NET 3.5

l On the Features page, enable these features:

o .NET Framework 3.5 Features > HTTP Activation

o .NET Framework 3.5 Features > Non-HTTP Activation

o .NET Framework 4.6 Features > WCF Services > TCP Activation
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Note: Microsoft SQL Server and Analysis Services must be installed on the same machine
with the same instance name.

This section tells you how to install and set up Sage 200 BI.
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Install Business Intelligence

Set up SQL server

Use multidimensional mode for analysis services
When you install SQL Server Analysis Services, youmust choose to set the server to use
Multidimensionalmode, and not Tabularmode or PoverPivotmode.

This option is available in SQL Server version 2012 onwards, and is set during installation for the
Analysis Services Server Configuration. By default, the Tabular Mode is selected, but this must
be changed toMultidimensional and Data Mining Mode.

Default accounts
We recommend that you use the default accounts set up by the SQL server installation wizard.

Set up the user account for Analysis Services
The start up account for SQL Server Analysis Services is not set up with a SQL login on the
database instance.

Note: This will be theNT Service\MSSQLServerOLAPService user if you used the default
accounts when installing SQL server.

Before you can access the BI cubes, you must add this user as a SQL login and set the server role
to public and sysadmin.
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To do this:

1. Make a note of theAccount Name for your SQL Server Analysis Services (SQL Server
Configuration Manager > SQL Server Services > SQL Server Analysis Services |
Properties).

For example: this will beNT Service\MSSQLServerOLAPService if you used the default
accounts when installing SQL server.

2. Add this account as a new login in SQL Server Management Studio > Security Logins).

3. Add the Server Roles. Select the sysadmin and Public roles.

Change the permission level after completing the
installation
Once you have set up Sage 200 BI and all of your data warehouses have been created, we
recommend that you reduce the permission level this account by removing the sysadmin role
and mapping to the db_datareader role.

Note: This will be theNT Service\MSSQLServerOLAPService user if you used the default
accounts when installing SQL server.

To do this:

1. Remove the sysadmin server role. Only the public role should remain selected.

2. Map your data warehouses databases to the to the db_datareader.

a. Select User Mapping.

b. For each of your data warehouses, selectMap and select db_datareader role. Make sure
only the public and db_datareader roles are selected.

Install BI
Note: Microsoft .NET Framework version 3.5 must be installed on both server and client
machines

1. When you first install the Sage 200 Server, make sure you choose to Install Sage 200
Business Intelligence.

After installing the Sage 200 server, the server PC will include installers in C:\Sage\Installers
for:

l Sage 200 BI Client: Includes the BI Admin Tool and the BI Excel Addin.

l Sage 200 Client: Sage 200 desktop app.

78



Sage 200c Professional

2. On the server PC, install the BI Client and Sage 200 Client.

l Install the BI Client.

Browse to C:\Sage\Installers\Sage 200 BI Client and run Sage200BIClient.msi.

l Log in as the scheduled task user, and install the Sage 200 Client.

Browse to C:\Sage\Installers\Sage 200 Client and run Setup.exe.

Make sure you're logged in as the Windows user that's set to run the scheduled task,
when you install the Sage 200 Client. For more information on the scheduled task, see
Configure the scheduled task on page 88.

l If any other user will run the BI Admin tool on this server, log in and install the Sage 200
Client for that user.

Note: If the PC has User Access Control enabled, and the user is not an administrator,
log in as the administrator before you install the Sage 200 Client. You must log in as
the administrator (not the user), so that the administrator credentials will be used to
run the BI Admin Tool.

3. For any other PCs where you will install and run the BI Admin Tool, you will also need to also
install the Sage 200 Client.

l To install the Sage 200 Client, use the Sage 200 Client link on the Sage 200 Installers web
page and run Setup.exe.

Note: If the PC has User Access Control enabled, and the user is not an administrator,
log in as the administrator before you install the Sage 200 Client. You must log in as
the administrator (not the user), so that the administrator credentials will be used to
run the BI Admin Tool.

4. For any other PCs where you will run the BI Excel Addin.

l To install the BI Excel Addin, use the BI Client link on the Sage 200 Installers web page and
run Sage200BIClient.msi.

Choose to install the Sage 200 Business Intelligence Excel Addin.
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Set up windows users for the BI
Admin tool
You must install and use the BI Administration tool on the server hosting Sage 200c Professional
to create and maintain your BI cubes. The BI cubes data is refreshed regularly. This data refresh is
performed by Windows Scheduled Tasks.

Note: You must be a member of the Sage 200 Administrators group to access the BI
Administration tool.

If the domain controller for the scheduled tasks is on Server 2012 or 2012 R2 and the BI
Admin tool is installed on Windows 7, you must install the following: Microsoft KB 2830145.

Required permissions to access the BI
Admin Tool
BI uses your Windows user account details to access the BI Administration tool. To access the BI
Administration tool, your windows user account must be:

n A domain user as long as they are an administrator in Analysis Services (see Microsoft SQL
Server security settings),

n A member of the Sage 200 Administrators group.

n Have access to the relevant company in System Administration.

n A domain user that has 'dbcreator' level permissions in SQL Server.

Note: To refresh cubes manually in the BI Admin Tool, you will need the same SQL
permissions as the scheduled task user.

Create a Windows user account for the
scheduled task
You must specify a windows user account that will run the scheduled task for BI to update the
cubes. Note that you cannot now use the Local System account, which was possible in earlier
versions of Sage 200.
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We recommend that you create a windows user account specifically for this task. The user
specified to run the Windows Scheduled Task must:

n Have a secure password that never expires.

We recommend that you keep a note of the password for this account until you have set up
the BI Administration tool and the scheduled task is running successfully.

n Have the following privileges:

l Be a member of the Sage 200 Administrators group.

l Have access to the relevant Sage 200 company.

l Be a local administrator on the Sage 200 server.

l Be an administrator in Analysis Services.

l Be a user in SQL Server with sysadmin access.

Note: If this user does not appear in the user list in the BI Admin tool, we recommend that
you create a new user in Active Directory. This is due to the Windows user not having aUser
Principle Name. A User Principle Name is a part of the Active Directory user information. This
information is sometimes missing on older user accounts, especially if they have been
migrated from an older version of Active Directory and the domain administrator account.

As the BI data is generally refreshed overnight, it is important the that the server is powered on
overnight so the Windows Scheduled Tasks can run.
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Set up security for Business
Intelligence
You must make sure that the appropriate users have access to the BI SQL database, and that the
SQL database and Microsoft Analysis Services are included in your firewall exceptions list.

This allows non administrator users to have access to the BI database.

1. Choose Start > Programs > Microsoft SQL Server > SQL Server Management Studio.

2. From the Server type, select Analysis Services.

3. From the Server name list, select the required instance and click Connect.

4. Right-click on the server instance and choose Properties.

5. From the Select a page list, choose Security.

6. Click Add.

7. Enter the name of each BI user in the format, DomainName\Username and clickOK.

The names you have added are listed

8. Enter the name of the domain user you will use to run the BI Admin tool in the format
DomainName\Username and clickOK.

9. When you have added all the required users, clickOK in theAnalysis Server Properties
window.

Set up Windows Firewall
If you are using Windows Firewall, you need to ensure that the Microsoft SQL database and
Analysis Services programs are included in the firewall exceptions list:

n SQL Server (sqlservr.exe).

n SQL Analysis Services (msmdsrv.exe).
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n If you are using named instances of SQL and Analysis Services, also include SQL Browser
Service (sqlbrowser.exe).

1. Choose Start > Settings > Control Panel.

2. OpenWindows Firewall.

l If you are using Windows Vista, click Allow a program through Windows Firewall.

3. Select the Exceptions tab.

4. Add the SQL Server application to the exception list of allowed programs:

a. Click Add Program, then click Browse.

b. Browse to the program file for SQL Server - sqlservr.exe.

Typically, this file will be located in Program Files\Microsoft SQL Server\MSSQL\Binn.

c. ClickOpen then clickOK.

The program is added to the exceptions list.

5. Add the SQL Analysis Services application to the list of allowed programs:

a. Click Add Program, then click Browse.

b. Browse to the program file for SQL Analysis Services -msmdsrv.exe.

c. ClickOpen then clickOK.

The program is added to the exceptions list.

6. Users running named instances of SQL and Analysis Services also need to add the SQL
Browser Service program to the exception list of allowed programs:

a. Click Add Program, then click Browse.

b. Browse to the program file for the SQL Browser Service - sqlbrowser.exe.

c. ChooseOpen then OK.

The program is added to the exceptions list.
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Set up Business Intelligence in
System Administration
Before you can access Sage 200 BI, you must authorise the BI features for the appropriate roles in
the System Administration.

1. OpenSystem Administration.

The Core Components for Business Intelligence are installed the first time you log on to Sage
200 System Administration after installing BI.

2. From the Navigation Bar, select Roles.

3. Select the Role that you want to use BI. Right-click and select Features.

4. Make sure BI Reports is selected.

5. ClickOK.

For more information about user accounts, role, and features, see the Sage 200 help:
desktophelp.sage.co.uk/sage200/professional/help.htm#SAA/FeaturesNode.htm.
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Configure Microsoft Excel to
use the BI add-in
You must enable the Sage BI Excel Add-in to use it with Microsoft Excel.

The BI reports use macros. If your Microsoft Excel security settings are set too high, some of
these macros will not run and you will see a warning on the report. To make sure the macros run
without a warning, we recommend that you set up a trusted location for your BI reports in Excel.

If you do change your Microsoft Excel security settings, potentially unsafe macros may run when
you open other workbooks created outside BI. Therefore we recommend that when you use
Microsoft Excel without BI, you disable the Sage BI add-in. This resets the Microsoft Excel security
settings and Excel will start more quickly.

Enable the Sage BI Excel add-in for Sage
200c
1. Choose Start > Sage Tools > Sage 200 > Enable or Disable Sage BI.

l To use Microsoft Excel with Sage BI, select Enable the BI Excel Add-in.

l To use Microsoft Excel without Sage BI, select Disable the BI Excel Add-in.

2. ClickOK.

Set up a trusted location for BI in Microsoft
Excel
To do this you must add the shared Sage folder on your server to the list of trusted locations on
each client PC that uses BI.

1. In Microsoft Excel, select the File tab and then clickOptions.

2. Select Trust Center and then choose Trust Center > Trust Center Settings > Trusted
Locations.

3. Make sure that theAllow trusted locations on my network is selected.

4. Click Add New Location.

5. Enter or browse for the location of the shared Sage folder on your server.
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6. Select Subfolders of this location are also trusted.

7. ClickOK.
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Configure the BI admin tool and
set up the scheduled task
Use the BI Admin tool (Start > Programs > Sage Tools > Sage 200 > Sage 200 Business
Intelligence Administration) to:

n Apply various report settings such as discount bands, analysis codes, report layouts and the
financial period.

n Create a new data warehouse for a company.

n Change the details of the scheduled task, for example, the time and frequency of the cube
update.

n Upgrade the data warehouse for the selected company. Use this when you have installed a
new version of Sage 200.

n Refresh the cubes for the selected company. Use this if you have changed your report
settings.

Create a new data warehouse and create
the cubes
Important
This task must be carried out on the server hosting Sage 200c Professional. You must be
logged on to the server with a user that has administrator privileges.

To build the cubes for a company, you must add a new data warehouse for each company.

1. On theData Warehouse Configuration window, clickNew warehouse.

2. From theCompany drop-down list, select the first company you want to configure.

3. Enter a unique name for your Data Warehouse and Analysis Services cube in the respective
boxes. ClickOK. A Scheduler Securitywindow appears.
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4. Enter or browse for the details of the windows user to run the Windows Scheduled Task.
Select the user you have set up for the scheduled task. See Set up windows users for the BI
Admin tool on page 80.

A progress bar appears indicating that the warehouse and cubes are being updated. This
process may take some time to complete. Once completed:

a. A data warehouse is created.

b. The cubes are built.

c. A scheduled task is created which rebuilds the cubes nightly at 3 am.

If required, you can change the settings for this scheduled task.

Upgrade a warehouse
If you're upgrading an existing version of BI, you will also need to update the corresponding
warehouse database so that the version numbers of both databases match.

n Click Upgrade Warehouse to update the database version of the selected warehouse. This will
also refresh the cubes.

Configure the scheduled task
Note: Scheduled Tasks is a Microsoft product. For help on Scheduled Tasks, please refer to
the Microsoft Windows help file.

1. Click Schedule tasks. The Task Scheduler appears.

2. From the left-hand pane, select Task Scheduler Library.
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3. Right-click theUpdateCube task for the required company and select Properties.

4. Select the Windows user account that you have created for the scheduled task.

5. Make any other required changes to the task and clickOK.

Refresh the cubes
Use refresh cubes to rebuild the cubes for a company. If you have changed your report settings,
you must refresh the cubes for the changes to take effect.

n Click Refresh cubes to update the cubes for the selected company. A message appears
showing the progress of the update.

This may take some time to complete, depending on the size of the database.
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Apply BI report settings
1. On theData Warehouse Configuration window, highlight the required company.

2. Click Report settings.

3. On theGeneral tab, use the Period and Year drop-down lists to select the default accounting
period and year that you want to use for your reports.

Note: If you leave the Period and Year boxes blank, the current date is used to determine
the default accounting period and year.

4. Use theMonth and Year drop-down lists to select the default calendar month and year that
you want to use for your reports.

Note: If you leave theMonth and Year boxes blank, the current date is used to determine
the default calendar month and year.

5. On theNominal tab, use the drop-down lists to select the default financial statement layouts
for your Balance Sheet and Profit and Loss reports.

6. On theCustomers tab, in theDiscount Bands boxes, type the lower percentage rate for each
band. These must be in ascending order.

The discount bands are used to group settlement discounts on invoices. If you do not enter
any discount bands, you will only see the Zero and >0% discount bands in your reports.

For example:

If you enter 2 for Band 1, 4 for Band 2 and 6 for Band 3, you will be able to select the following
discount bands in the reports:

l Zero, 0-2%, 2-4%, 4-6% and >6%.

A discount of 2% will fall in the 0%-2% band and not the 2%-4% band

7. If you only want to bring through the Analysis Codes you have named, select Show Named
Customer Analysis Codes Only and Show Named SOP Analysis Codes Only. Otherwise all
Analysis Codes will be brought through to the cubes.

Note: If you have set up the Sales Ledger to use separate trading periods, you can select
the default trading period you want to use for your reports. Select this from theCurrent
Sales Trading Period drop-down list.

8. On the Suppliers tab, complete all theDiscount Bands boxes as appropriate.
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9. If you only want to bring through the Analysis Codes you have named, select Show Named
Supplier Analysis Codes Only and Show Named POP Analysis Codes Only. Otherwise all
Analysis Codes will be brought through to the cubes.

Note: If you have set up the Purchase Ledger to use separate trading periods, you can
select the default trading period you want to use for your reports. Select this from the
Current Sales Trading Period drop-down list

10. On the Stock tab, select all the Search Categories as appropriate. You can use these for
analysis on your reports.

11. If you only want to bring through the Analysis Codes you have named, select Show Named
Stock Analysis Codes Only. Otherwise all Analysis Codes will be brought through to the
cubes.

12. On the Project tab, select theAdditional Information fields as appropriate.

You must specify which of the project Additional Information fields in are Text, Numeric, date
and time (Time), a yes or no answer (Boolean) or a selection from your lists of products,
customers, suppliers or resources (ID).

13. When you have entered all the required information, click Save.

You can now create a data warehouse and build the cubes.

Note: If you later change your report settings, you will only see the changes take effect
after the cubes have been updated. The cubes will usually be updated by running a
scheduled task, but if you want to update the cubes manually see Refresh the cubes on
page 89.
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Upgrading an existing
installation of BI
Follow the instructions in this section to upgrade an existing installation of Sage 200 Business
Intelligence.

1. Make sure that the Windows user accounts for users that will access the BI Administration
tool are:

l A domain user as long as they are an administrator in Analysis Services (see Microsoft SQL
Server security settings),

l A member of the Sage 200 Administrator group.

l Have access to the relevant company in System Administration.

l A domain user that has 'dbcreator' level permissions in SQL Server.

2. If you haven't already done so, create a windows user account for the scheduled task that
updates the BI cubes. See Set up windows users for the BI Admin tool on page 80

3. Back up all databases (including data warehouses and analysis services databases).

4. Uninstall Sage 200.

5. Choose to install the following components on the server:

l The Sage 200 server.

Don't forget to select BI in the installation wizard.

l The BI Client

l The Sage 200 Client.

You must make sure you're logged in as the Windows user set to run the scheduled
task when you install the Sage 200 client. This is to make sure the DLL files for the
scheduled task are installed correctly.

See Install Business Intelligence on page 77.

6. Install the following components on all client machines that will be running BI.

a. The desktop app. Click the Sage 200 Client link on the Sage 200 Installers web page and
run the Setup.exe file.

b. The BI client app. Click the BI Client link on the Sage 200 Installers web page and run the
Sage 200 Client.msi file.
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7. Make sure the scheduled task is set up on the server with Sage 200c installed. In previous
versions, the scheduled task could be installed on a separate machine with SQL Server.

a. Check that the user account used to run the scheduled task is the windows user account
that you have created for this purpose.

b. Each company that uses BI must have a separate scheduled task.

See Configure the scheduled task on page 88.

8. Upgrade your Sage 200 databases for all companies that also use BI, in System
Administration.

Note: Youmust upgrade your Sage 200 databases to Sage 200c Professional before you
upgrade your BI data warehouse.

9. Upgrade each data warehouse in the BI Admin Tool.
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Troubleshooting BI
Use this section for a an explanation of some common errors that may occur in Sage 200 BI. This
covers the following errors:

BI Administration tool

n Changing your Sage 200c database? on page 95

n Backing up and restoring BI databases on page 96

n Losing cube changes after an upgrade? on page 96

n Manually creating a scheduled task to update the cubes on page 96

n Sage BI Admin tool takes a long time to open on a PC with no internet access on page 97

n Data not populating 'As At' date when creating a Data Warehouse on page 97

Excel Add-in for BI

n Failed to link to database error on page 97

n Re-enabling the Sage 200 BI Add-in in Excel on page 98

n Sage BI tab missing when launching Excel on page 98

n Excel security warning when opening a report on page 98

n Excel 2013 on page 98

Error updating the cubes
You'll see this error if you weren't logged in as the scheduled task user when installing the Sage
200 client on the server machine.

To resolve this, log onto the server as the windows user for the scheduled task and re-install the
Sage 200 desktop app.
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BI Administration tool
Cubes not updating or get a missing DLLs message when opening the
admin tool?
Your cubes will not be updated and your BI reports will not show up to date information if your
scheduled task is not running.

The scheduled task won't run if you weren't logged in as the user set to run the scheduled task
when you installed the Sage 200 desktop app (client) on the server.

To resolve this you just need to log onto the server as this user and re-install the desktop app.

Changing your Sage 200c database?
If you want to use a different Sage 200c database for your company, you must delete your
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existing warehouse and cubes and rebuild them.

Backing up and restoring BI databases
To backup or restoreyour BI warehouse database use Microsoft SQL Server Management Studio.

The Sage 200c company database must remain in sync with the BI warehouse database and
Analysis Services database. Therefore, if you backup or restore your company database you
should restore the BI warehouse database and Analysis Services database at the same time.

Losing cube changes after an upgrade?
If you customise your cubes (e.g. add new fields), those changes will be lost when you upgrade to
a new version of BI or use theUpgrade warehouse option.

Manually creating a scheduled task to update the cubes
Important: Scheduled tasks must be created on the server hosts Sage 200c Professional. This will
avoid problems related to connection issues when the user is not present.

Note: The procedure below describes how to manually set up a task using Windows 7. There
will be differences in this procedure when using other versions of Windows. Scheduled Tasks
is a Microsoft product. For help on Scheduled Tasks, please refer to the Microsoft Windows
help file.

1. Choose Start > Control Panel.

2. Open System and Security > Administrative Tasks > Schedule Tasks.

3. Select the Task Scheduler Library.

4. Select Create Task from theActions pane.

5. Enter a name for the task.

6. Select the user you have specified to run the scheduled task.

See Before using the BI Admin tool.

7. Select Triggers and clickNew.

8. Select the required options for performing the task and click OK.

Note: It is advisable to rebuild the cubes on a daily basis outside of working hours so they
do not conflict with any backup operations.

9. Select Actions and clickNew.

10. Select Start a program from the Actions drop-down list.

11. Click Browse.

12. Select the file Program Files\Sage\Sage200\ScheduledUpdateCubes.exe and clickOpen.

13. Amend the path as follows (changes in bold), where the number after /n corresponds to the
company number in the Sage 200 BI Administration tool.

C:\Program Files\Sage\Sage200\ScheduledUpdateCubes.exe /n:1
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14. ClickOK.

15. ClickOK. The new task is added to the Scheduled Tasks.

16. To ensure your new task has been set up correctly, right-click the task and select Run.

Sage BI Admin tool takes a long time to open on a PC with no internet
access
If you are running the Sage 200 BI Administration Tool on a machine that does not have internet
access, it can take up to two minutes to open.

This occurs because the BI Admin tool needs to run with administrative credentials. In order to
ensure a secure connection, the tool attempts to checks for revoked certificates online.

To speed up opening the Admin tool, it is possible to turn off this check.

Important: This setting should only be changed on a PC that does not connect to the internet. If
the PC is later connected to the internet, the original setting must be restored.

1. Open Internet Explorer.

2. Select Tools > Internet Options > Advanced.

3. Scroll down the Settings list to the Security section.

4. Clear the checkbox for Check for publisher's certificate revocation.

5. ClickOK and close Internet Explorer.

Data not populating 'As At' date when creating a Data Warehouse
When the data warehouse is populated (either via a data warehouse update or a refresh), a
'snapshot' of that data is recorded and stored for the Sales Order and the Stock Level cubes.

If the date of the data extract is not in the financial year defined for the company, the data
warehouse will not be populated with any data.

A message will be written to the data warehouse audit trail (in the AuditHeader and AuditDetail
tables) to inform you that the update has failed.

BI Excel Add-in
Failed to link to database error
If you try to run a BI report and the message Failed to link to Database is displayed, this means
BI cannot connect to the Analysis Services database.

This will appear if you do not have permission to access Analysis Services. For information on
setting permissions, see Microsoft SQL Server security settings.
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Re-enabling the Sage 200 BI Add-in in Excel
If Sage 200 Business Intelligence has problems connecting to the database and fails, it can
become disabled as an add-in in Excel. The most common symptom of this is seeing the text
#NAME in the report cells. To re-enable the add-in:

1. From the Startmenu, select Program Files > Sage Tools > Sage BI > Enable or Disable Sage
200 Business Intelligence.

2. Select Enable.

3. ClickOK.

Sage BI tab missing when launching Excel
When you open Microsoft Excel, the Sage BI tab is not displayed.

To resolve this, you must check your Trust Center settings for Add-Ins.

1. Open File > Options > Trust Center > Trust Center Settings > Add-Ins.

2. Make sure that none of the options are selected.

Excel security warning when opening a report
When you open a BI report in Excel, you may see a security message warning you that the
document contains macros.

If you see this message, you must enable the macros for the BI reports to work correctly. To do
this:

1. Select Always trust macros from this publisher.

2. Click Enable Macros.

This action should only be required once for any user on any particular PC.

Excel 2013
Office 2013 must be fully activated to use the BI Add -In. If Office 2013 is not activated you may
experience issues with Excel.

98



Extending your system
This section tells you:

n How to make sure your SQL database is large enough.

n How to optimise your database to ensure maximum performance.

n How to allow 3rd party applications to access your Sage 200c data via the Sage 200 API.

n Recommendations for installing on virtual platforms.
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Sizing your system
A typical deployment of Sage 200c consists of all elements residing on the same server, which
also hosts the SQL server instance.

For larger sites with higher user counts and larger transaction volumes this deployment model is
not always suitable and may not offer the best performance.

The following diagram shows four different sized deployments of Sage 200c and gives some
suggested 'ball park' figures for sites that may fit into these scenarios. Due to the diverse nature
of businesses that use Sage 200c, it is impossible to give exact recommended specifications for
each scenario but these figures are based on data gathered from sites already successfully
running Sage 200c.
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Small deployments
Recommended for sites:

n 4 to 12 concurrent users.

n Database sizes less than 2GB.

n Not running Sage 200 CRM or Business Intelligence.

Recommended Specifications

Notes

Dual core processor The operating system will use one core with Sage 200 and Microsoft
SQL Server sharing the other core.

No configuration around setting processor affinity is required and in
practice the operating system, SQL and Sage 200 will share the cores,
along with other running applications, but a dual core system should
give users acceptable performance.

4GB RAM n 2GB for the operating system.

n 1GB for SQL.

n 1GB for Sage 200.

No configuration around setting memory allocation is required and the
operating system, SQL and Sage 200 will share the available memory,
along with other running applications.

A minimum of 4GB server memory should give users acceptable
performance in this scenario.

7.2K rpm SATA Disk Should be sufficient for databases less than 2GB.

Small deployments with CRM or Business Intelligence
Recommended for sites:

n 8 to 12 concurrent users.

n Database sizes less than 2GB.

Recommended Specifications

Notes

Dual core processor The operating system to use one core, and Sage 200 and Microsoft SQL

101



Sage 200c Professional

Notes

Server to share the other core.

As Sage 200 CRM is a browser based module that can require high
levels of server CPU when synchronising data or processing multiple
user requests at the same time. The server should have a minimum of a
dual core processor but as user count and data size increases towards
the top end of this bracket, a quad core processor may be preferable.

8GB n 2GB for the operating system.

n 1GB for SQL.

n 1GB for Sage 200.

n For BI: 1GB for each data warehouse / analysis services cube.

Sage 200 Business Intelligence uses Microsoft SQL Server Analysis
Services which can be a very memory intensive process. For each data
warehouse and analysis services cube created, we recommend
allocating at least 1GB RAM.

10K rpm SAS or SCSI In a RAID configuration to allow for failover.

Sage 200 CRM and Sage 200 BI will benefit from additional memory and
faster access disks.

Medium Deployments
Recommended for sites:

n 12 to 25 concurrent users.

n Database sizes less than 10GB.

Where sites have more than 20 concurrent users accessing Sage 200 CRM with similar levels of
users accessing Sage 200 Accounts at the same time, it is recommended to split out Sage 200
CRM onto a second server to improve performance.

Recommended Specifications

Server Specifications Notes

Server 1

Quad core
processor

n Microsoft SQL Server.

n Sage 200c database.

n Sage 200 CRM database.

n BI.

This server is effectively dedicated to handling the SQL requests of Sage
200c.
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Server Specifications Notes

8 - 16 GB
RAM

n For BI, allow at least 1GB for each data warehouse and analysis
services cube.

Business Intelligence uses Microsoft SQL Server Analysis Services
which can be a very memory intensive process. For each data
warehouse and analysis services cube created, we recommend
allocating at least 1GB additional Ram but this requirement will
increase with database size.

n With Remote Desktop Services, add 1 GB for each remote user
session, up to a maximum of 8 remote users.

For more than 8 remote users, use a separate Remote Desktop
Services server running the Sage 200c client.

See Supported software on page 12

10K rpm
SAS or
SCSI Disk

n In a RAID configuration to allow for failover.

n The SQL data and log files ideally being hosted on different disks to
the operating system.

Server 2

Quad core
processor

n Sage 200 server.

n Sage 200 CRM installation (not the database).

n Additional services such as Sage 200 Self Service.

4 - 8 GB
RAM

7.2K SATA
Disk

Large deployments
Recommended for sites:

n 25 to 50 concurrent users

n Database sizes over than 20GB.

Recommended Specifications

Server Specifications Notes

Server 1

2 x Quad
core
processor

n Microsoft SQL Server.

n Sage 200 database.

n Sage 200 CRM database.

n BI
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Server Specifications Notes

This server is effectively dedicated to handling the SQL requests of Sage
200c

16 - 32 GB
RAM

n For BI, allow at least 1GB for each data warehouse and analysis
services cube.

Business Intelligence uses Microsoft SQL Server Analysis Services
which can be a very memory intensive process. For each data
warehouse and analysis services cube created, we recommend
allocating at least 1GB additional Ram but this requirement will
increase with database size.

n With Remote Desktop Services, add 1 GB for each remote user
session, up to a maximum of 8 remote users.

For more than 8 remote users, use a separate Remote Desktop
Services server running the Sage 200c client.

10K or 15K
rpm SAS
or SCSI
Disk

n In a RAID configuration to allow for failover.

n The SQL data and log files ideally being hosted on different disks to
the operating system.

Server 2

Quad core
processor

n Sage 200 Server.

n Sage 200 CRM installation (not the database).

n Additional services such as Sage 200 Self Service.

16 GB
RAM

7.2K SATA
Disk

Remote
Desktop
Services

Server

Quad Core
Processor

RAM

10K rpm
SAS or
SCSI disk

With Remote Desktop Services, use a separate server for more than 8
remote users.

Allow sufficient memory to allow for 2GB for the operating system and
an additional 1GB per remote session running the Sage 200c client, up
to a maximum of 12 users per server.

Recommended specifications for client machines
In addition to calculating the system requirements for the servers running Sage 200c, you must
also consider the client machines that will be running Sage 200c. The application footprint on
each of the client machines can be large.
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Processing of tasks is carried out using CPU and memory resources on both the client and the
server, and the specification of both machines will affect the overall performance of the system.
The following table gives an example of this.

Profile Running Year End with 1 million Nominal Transactions

Server A / Client A 3 hrs 24

Server A / Client B 5 hrs 07

Server B / Client B 8 hrs 11

The server and client specifications were as follows:

Server A = 2 x Quad Core 2.4GHz Xeon, 8GB Ram, 15K SAS Disks, Gigabit Network

Server B = 1 x Dual Core 2.6GHz, 4GB Ram, 7.5K SATA Disk, Gigabit Network

Client A = 1 x Dual Core 2.6GHz, 4GB Ram, 7.5K SATA Disk, Gigabit Network

Client B = 1 x Single Core 2.8GHz, 2GB Ram, 7.5K SATA Disk, Gigabit Network

Client machines used to run long batch processes, such as Update Waiting Postings and Month
and Year End processing, should be dual core processor machines with 4GB RAM.
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Sizing your database
The size of the database will depend on a number of factors, not just the number of transactions
included within the database. The following examples can be used to estimate a rough minimum
expected database size given a specific number of records but be aware that with SQL database
padding this size can increase 10 fold. Use these examples to calculate minimum disk
requirements only.

The following record sizes are calculated using Sage 200 demonstration data for 8 financial years.

Record Type Record Size (in KB)

Sales Ledger Record 24K

Purchase Ledger Record 15K

Nominal Ledger Record 14K

Stock Record 4K

SOP Order (based on 4 item lines) 44K

POP Order (based on 4 item lines) 47K

Sales Ledger Invoice 3K

Purchase Ledger Invoice 4K

Nominal Ledger Journal 2K

To calculate the minimum disk space required, you can take these record sizes and multiply them
against the estimated number of records. For example:

Record Type Record Size (in KB) Number of Records Size

Sales Ledger Record 24K 10,000 240,000K

Purchase Ledger Record 15K 10,000 150,000K

Nominal Ledger Record 14K 800 11,200K

Stock Record 4K 16,000 64,000K

SOP Order 44K 12,000 528,000K

POP Order 47K 2,600 122,200K

Sales Ledger Invoice 3K 12,000 36,000K

Purchase Ledger Invoice 4K 14,000 56,000K

Nominal Ledger Journal 2K 140,000 280,000K

1,487,400K
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This gives an estimated database size of 1.4GB. The actual size of the database used in this
example was 1.2GB. The difference was made up of a variety of factors, such as not all records
were fully populated, not all orders had 4 item lines etc.

For further guidance, the following table gives record numbers and associated database sizes for
real Sage 200 databases. As you will see, some fit the calculation but some, such as the 6GB and
10GB database examples, are considerably larger than would be expected. This is largely due to
database padding and you should allow at least 2 or 3 times more disk space than the minimum
calculated to allow for padding and future growth.

No records / transactions

Sales Ledger

Records

10,000 1,000 3,500 45,000 300 25,000 28,000

Purchase Ledger Records 10,000 100 600 800 2,000 500 1,000

Nominal Ledger Records 800 100 300 150 600 600 3,000

Stock Records 16,000 400 1,500 16,000 50,000 800 12,000

SOP Orders 12,000 3,500 85,000 125,000 6,000 115,000 350,000

POP Orders 2,600 0 20,000 4,000 14,000 1,700 56,000

Sales Ledger Transactions 12,000 45,000 68,000 220,000 10,000 175,000 950,000

Purchase Ledger Transactions 14,000 0 15,000 17,000 56,000 10,000 80,000

Nominal Ledger Transactions 140,000 100 420,000 610,000 116,000 295,000 5,000,000

Database Size in Gigabytes 1.2 3.0 4.0 5.5 6.0 10.0 25.0

Real Sage 200 database sizes

As you will also see from the table above, the database can scale up to very large numbers of
transactions. The 25GB example has over 5 million nominal transactions.
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Database configuration and
maintenance
Once you have sized your system, you can start looking at optimising access to the database to
ensure maximum performance. For smaller databases this is not so essential but as the database
increases in size, especially once it starts getting over 4GB, real performance improvements can
be obtained by having appropriate database configuration and maintenance plans in place.

Setting up a Database Maintenance Plan
We strongly recommended that you set up a database maintenance plan as part of your Sage
200c deployment. You should include both the Sage 200c and CRM databases in the
maintenance plan.

For detailed information on setting up the tasks and plan for SQL Server please refer to the
manufacturer's web site but we recommend the following:

To set up a new database maintenance plan for Microsoft SQL
Server
1. Open Microsoft SQL Server Management Studio and connect to the instance of SQL that

hosts your Sage 200c and CRM databases.

2. Right clickManagement > Maintenance Plans and selectMaintenance Plan Wizard.

3. Follow the steps in the wizard until all the tasks have been defined. We recommend that you
include the following:

l Check Database Integrity – We recommend that you run this nightly for both the Sage
200c and CRM databases.

l Shrink Database – Avoid this option for large or rapidly growing databases. see the
following section on Disk Management on page 109 for further advice on database size.

l Reorganize Index – We recommend that you run this nightly for both Sage 200c and CRM
databases.

l Rebuild Index – We recommend that you run this weekly for both Sage 200c and CRM
databases.

l Update Statistics – We recommend that you run this nightly for both Sage 200c and CRM
databases.

You should only run maintenance plans 'out of hours' when no users are on the system. We
recommend that you run the plan once initially to ensure the plan completes successfully and
then schedule the tasks to run automatically overnight.
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Before any maintenance tasks can be run, check that the SQL Server Agent is running.

Disk Management
If you have a large deployment, the databases for Sage 200c and Sage 200 CRM can grow rapidly
as large numbers of transactions are recorded. Rather than letting SQL Server adjust the size of
your database as it grows, we recommend that you pre-empt this growth manually by disabling
theAuto Shrink and Auto Grow options within SQL Management Studio and manually padding
the database to accommodate future growth.

To Disable Auto Shrink
1. Open Microsoft SQL Server Management Studio and connect to the instance of SQL that

hosts your Sage 200 and CRM databases.

2. Right click Databases > <Sage 200 database name>, and select Properties.

3. Choose theOptions page.

4. Set Auto Shrink to False.

5. Repeat for your Sage 200 CRM database.

To manually grow your database
1. Open Microsoft SQL Server Management Studio and connect to the instance of SQL that

hosts your Sage 200 ERP and CRM databases.

2. Right click Databases > <Sage 200 database name>, and select Properties.

3. Choose the Files page.

4. For both the MDF and LDF files, click the browse button in theAutogrowth column.

5. Set the File Growth > In Megabytes value to an amount of disk space that will allow for
plenty of growth.

For example, if your current database is 2GB, you could set this value to 6GB. Increasing this
value does not increase the size of your SQL backups.

6. Repeat for your Sage 200 CRM database.

Other Disk Management Tips
n Separating the operating system and database onto their own separate drives is best practice

for large databases to make sure that Windows and system disk don't compete with SQL IO
requests.

n Make sure that the space you're allocating to the MDF/LDF files is largely contiguous and kept
defragmented.

109



Sage 200c Professional

n The Sage 200c database must remain synchronised with the Sage 200 CRM and BI warehouse
and analysis services databases.

Make sure you backup or restore Sage 200 CRM and the BI warehouse and analysis services
databases at the same time as your main Sage 200c database.

Database management for Sage 200 Business
Intelligence
For BI, if you need to recover to a specific point in time (i.e. just before the disaster happened) and
wish to avoid hard disk space issues, we recommend that you:

1. Set up a disaster recovery model.

2. Reduce the size of the log file.

This is because the data warehouse's database log file grows when the data warehouse is
upgraded and cubes refreshed using the BI Admin tool. This growth is usually proportional to the
number of record updates performed on the data warehouse.

If you have a relatively large database, the data warehouse's log file will grow significantly every
time the data warehouse is updated. This can lead to disk space problems on the database server
fairly quickly for large datasets, and over a longer period of time for smaller datasets.

However the log file contains information about all the changes made to the data warehouse
required for the database administrator to perform any required disaster recovery procedures.

Set up a disaster recovery mode
The disaster recovery mode that you choose for the data warehouse database depends on how
you use BI.

When 'As At' cubes are updated, data is pulled down from Sage 200c to provide a typical snap
shot of your data for a specific point in time. The recovery mode that you choose depends on
whether you need to recover your data this specific point in time or whether the accuracy of the
as 'as at' data is not crucial, i.e. the snap shot is out by one day.

You can choose one of the following modes:

n Full - choose this to recover data to a specific point in time.

This uses full, differential and transaction log backups to provide the best protection against
failure. It allows the database to be restored to the point of failure or to a specific point in time.

n Simple - choose this if the accuracy of the "as at" status of the BI reports is of low importance.

This recovers data to the most recent successful full database or differential backup. The
underlying transaction logs are truncated each time a checkpoint is issued for the database.
This mode restricts the database log file growth.
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To set the data recovery mode
1. Open Microsoft SQL Server Management Studio and connect to the instance of SQL that

hosts the BI databases.

2. Right click Databases > (data warehouse database name), and select Properties.

3. Choose theOptions page.

4. Select the required Recovery model.

Reduce the database size
1. Set the data warehouse database to "restricted user" mode.

This prevents new connections being made to the database for users who do not have
appropriate roles assigned.

This will be blocked until users are already connected to the database have close their
connection. This ensures that no transactions are rolled back unexpectedly (i.e. a user in the
middle of updating the warehouse).

Follow the steps below or run the following SQL script: [ALTER DATABASE database-

name SET RESTRICTED_USER].

a. Open Microsoft SQL Server Management Studio and connect to the instance of SQL that
hosts the Sage 200 BI databases.

b. Right click Databases > <data warehouse database name>), and select Properties.

c. Choose theOptions page.

d. In theOther options > State section, set Restrict Access to RESTRICTED_USER.

2. Backup the transaction log and database.

a. Right -click the data warehouse database and select Tasks > Backup

b. Make a Full backup if you don't already have one, otherwise skip to the next step.

c. Run the SQL command [checkpoint] against the data warehouse database. This flushes
the contents of the transaction log into the main database files.

d. Make a Transaction Log backup. Make sure that Truncate the transaction log is selected
on theOptions page. This is only be available if your database is in Full Recovery or Bulk
Loggedmode.

e. Make a Full backup of the database.

3. Shrink the database.

a. Right -click the data warehouse and select Tasks > Shrink > Database.

b. Verify that the database log file is now reduced in size.

4. Remove the Restricted user set in step 1 by either reversing the steps or by running the
following SQL script: [ALTER DATABASE DATABASE-NAME SET MULTI_USER].
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Install Sage 200 API on an
external facing web server
If you want to use any 3rd party applications that access your Sage 200c data via the Sage 200
API, you'll need to install the Sage 200 API service on a machine that can be accessed externally
from the Internet, either from mobile devices or machines that are not joined to your domain. It is
good practice to separate this service out onto it's own server so that if your network is
compromised your data is protected behind a separate firewall for your SQL server.

In order to do this you will need:

n An external facing web server with internet access to host the API web site.

n A commercially available SSL Certificate to verify your domain and secure the web site.

n A registered domain name to direct traffic to the web site.

We recommend that you purchase any required domain names and SSL certificates and
configure them to point to your external facing web server. Speak to your service provider for
advice on how to do this.

Before you install the API service on an external facing server, you must have installed and fully
configured Sage 200c on your server and you must be able to log into Sage 200c.

Prerequisites
The machine hosting the API Service must be joined to the same domain as the server hosting
Sage 200c and have the following installed:

n Microsoft .NET Framework 4.5.2 (or later).

Note: This may already be included if you have installed a later version of .NET Framework.

n .NET Framework 4.5 (or later) Features with HTTP Activation.
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n Windows Identity Foundation. This can be added as a feature.

n Microsoft Internet Information Services (IIS) v8 or greater, with the following settings.

Common HTTP Features Default Document

Directory Browsing

HTTP Errors

HTTP Redirection

Static Content

Application Development .NET Extensibility 4.5 (or later)

ASP

ASP .NET 4.5 (or later)

ISAPI Extensions

ISAPI Filters

Security Request Filtering

Management Tools IIS Management Console

Management Tools > IIS 6 Management Compatibility IIS 6 WMI Compatibility

IIS 6 Metabase compatibility

To install the API Service
Follow these instructions to install the API Service on your external server.

1. Download the API installer from the Sage support website.

2. Right-click the Sage200API.exe file and choose Run as Administrator.

3. Follow the instructions on the installer. Make sure that you:

a. Change the path to the Logon directory to the location of your server :
\\<servername>\Sage\Logon.

b. Enter the name and password of the windows account that you set up to run the Sage 200
Services.

To secure the API web site with your SSL certificate
Once you have installed the API web site on your external server machine, you need to amend the
web site bindings in IIS to use the external SSL certificate and set up firewall rules on both your
Sage servers.
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1. Open Internet Information Services (IIS) Manager.

2. Expand the list of websites and choose Sage 200 API.

3. Right-click and choose Edit Bindings.

4. ChooseAdd and change the type to https.

5. Set this to a port number that's not currently in use.

6. From the SSL certificate drop-down menu, choose your external SSL certificate.

Note: This is not the Sage 200 API SSL Certificate.

7. ClickOK.

Note: You may see a message informing you that another site is using the same HTTPS
binding. Click Yes to apply the binding to this site.

8. ClickOK to close theAdd Bindings window.

9. Click Close to close the Site Bindings window.

The Sage 200 API web site is now using your external SSL certificate.

To set up your firewall rules
To increase the security of your deployment you must configure the Windows firewall on both of
your Sage servers. The following table details the ports that need to be opened in order for Sage
200c to function correctly.

Sage 200 Server (Inbound Rules) TCP Port Sage 200 App Services(Default 10443)

SQL Server (Inbound Rules) TCP Port SQL Server (Default: 1433)

Sage 200 API Service Server (Inbound Rules) TCP Port set up for the API.

Check you can access the API service from another
machine
1. Enter the following location in your browser: https://<HostName>/sage200api/internal/api_
status. The <host name> is the name specified when you created a binding for the API site.

2. If the page returned has a value of 1, then the API can be accessed externally.

If this is not returned, then please contact your own IT support for further assistance.

Activate the API in System Administration
Once you've installed the API Service, you must:
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1. Register your Sage ID for the Sage 200 API. A Sage ID is used to give your company access to
the Sage 200 API and to log on to your apps. If you don't have a Sage ID already, you'll be
asked to create one.

a. Open System Administration > API.

b. Click Edit.

c. Click Register your Sage ID.

d. Follow the instructions to complete the registration.

2. Activate the API in System Administration:

You need to enter the URL for the public endpoint of the API. This will be your domain name
and end in /Sage200API, such as https://your domain name/Sage200API.

a. Open System Administration > API.

b. Click Edit.

c. Select API Enabled.

d. Enter a name for your site, This can be your choice.

e. Enter your Site URL.

f. ClickOK. You'll be prompted to log in with your Sage ID. The site status will show as
Pending until your licence has been updated.

You must enable the API before contacting Sage Partner Services to update your licence.

3. Add the API module to your licence and download an updated version.

Your Business Partner will need to call Sage Partner Services to request to add the API
module to your licence. You'll need to download the updated licence in System
Administration and check that the Sage 200 API has been enabled.

4. Create a Sage ID for every user who will access an app via the API, and specify which users
have access to the API on their User Properties.

a. Open System Administration > Users.

b. Double click the user's System name name, or right-click the user and choose Properties.

c. Select theAPI tab.

d. Enable Sage ID to allow this user to log onto third party apps which access your data via
the Sage 200 API.

e. Enter an email address for this user. This is the email address they'll use to sign in to Sage
ID to access the app.

The user will receive an email asking them to complete the registration process to create a
Sage ID.

f. On theCompany Access tab, check the companies the user can access. Users will only be
able to access companies via the app that they have access to here.

g. ClickOK.

For more details on how to do this, see the Sage 200c help.
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Installation options for
virtualised platforms
Due to the large number of virtualisation platforms it is not practical or feasible for Sage to test
them all. If you encounter issues while running client software in a client hosted virtualised
environment, you may be required to reproduce the issues in a standard (non-virtualised)
environment. Refer to the Products and Services Terms and Conditions here: www.sage.com/en-
gb/legal/terms-and-conditions/product-and-service-terms-and-conditions/.

Server hosted virtualisation
All elements of Sage 200c Professional are supported in a virtualised environment if the following
conditions are met:

n The underlying virtualisation platform has been accredited by the Microsoft Windows Server
Virtualisation Program. See www.windowsservercatalog.com/svvp.aspx for further details.

n The host operating system is one of the supported operating systems outlined in the system
requirements. See Supported software on page 12.

Sage 200c is also supported when running in a Microsoft Hyper-V virtualised environment which
is running one of the supported operating systems outlined in the System Requirements.

You must ensure that the server hosting the virtual machines is of sufficient specification to run
both the underlying operating system, and the virtual machine that Sage 200c is running on.

Client hosted virtualisation
The desktop app is supported when running in a client hosted virtualised environment, provided
that the virtualised environment is running a supported version of Windows. For example:

n The desktop app running in a Windows 7 VM hosted on Mac OS.

n The desktop app running in a Windows 8.1 VM hosted on Linux.
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Support for thin client
environments
n We support the use of Sage 200c using Remote Desktop Services (RDS).

n We do not support the use of Sage 200c using other thin client environments, such as Citrix.

Due to the variety ways that a thin client environment may be configured, it is not practical or
feasible for Sage to test them all. If you encounter issues while running Sage software in a thin
client environment, you may be required to reproduce the issues in a standard environment.
Refer to the Products and Services Terms and Conditions here: www.sage.com/en-
gb/legal/terms-and-conditions/product-and-service-terms-and-conditions/.

Remote Desktop Services (RDS)
Requirements for deploying Remote Desktop Services:

n The Remote Desktop Services installation must be deployed using Session-based desktop
deployment.

Deployment using Virtual-machine based desktop deployment is not supported.

n Sage 200c is only supported when publishing the whole desktop environment through
Remote Desktop Services.

Delivering Sage 200c as a RemoteApp solution is not supported.

For Remote Desktop Services servers hosting Sage 200c client sessions, we recommend:

n At least 600MB memory per user on the server, for each client session running occasional or
one-off tasks, such as an account enquiry or price check.

n At least 1GB memory for each client session processing for any prolonged period of time, for
tasks such as checking in stock, or creating purchase orders.

n You should run large batch processes and updates on the local area network, or out of hours.
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